Nameservers set ok but Cloudflare not detecting it


#1

HI, I have set my nameservers on my domain name hotels.td and cloudflare has even recogised it, but it has not allowed me control.

Im stuck on Complete your nameserver setup…
It says:
Change your nameservers from:
gwen.ns.cloudflare.com
lynn.ns.cloudflare.com

To:
gwen.ns.cloudflare.com
lynn.ns.cloudflare.com

??? I have tried clicking Re-check now many times? to no avail.
Been like this for 2-3 days now :frowning:

Anyone else got this? Bug in the system?

Thanks


#3

Did you update your nameserver records in your domain registrar?


#4

It’s a good thing that they did mention the domain: hotels.td. There seems to be a typo though:

DNS shows the domain is delegated as such:

hotels.td. 86400 IN NS lymn.ns.cloudflare.com.
hotels.td. 86400 IN NS gwen.ns.cloudflare.com.
;; Received 93 bytes from 2001:660:3006:1::1:1#53(ns-td.nic.fr) in 437 ms

But when I ask Cloudflare what nameservers should be used, we get something slightly different:

hotels.td. 86400 IN NS gwen.ns.cloudflare.com.
hotels.td. 86400 IN NS lynn.ns.cloudflare.com.
;; Received 93 bytes from 173.245.58.160#53(gwen.ns.cloudflare.com) in 35 ms


#5

My bad :blush:, apologies!


#8

Grr, Trying again… again…

Thanks for the post, it could well be a spelling mistake,l it has happened. its a manual process to add nameservers on the .td namespace (apparently).

When I run the following (from my home machine):

C:\Users\James>nslookup -type=ns hotels.td
Server: google-public-dns-a-REMOVED
Address: 8.8.8.8

Non-authoritative answer:
hotels.td nameserver = gwen.ns.cloudflare.com
hotels.td nameserver = lynn.ns.cloudflare.com

I do not see that spelling mistake? Am I missing something?

Cloudflares policy is restricting me from posting more than 2 “links”.

Regards,
J


#9

The typo is at your registrar:

dig hotels.td ns +trace @1.1.1.1

; <<>> DiG 9.12.3 <<>> hotels.td ns +trace @1.1.1.1
;; global options: +cmd
. 6215 IN NS a.root-servers.net.
. 6215 IN NS b.root-servers.net.
. 6215 IN NS c.root-servers.net.
. 6215 IN NS d.root-servers.net.
. 6215 IN NS e.root-servers.net.
. 6215 IN NS f.root-servers.net.
. 6215 IN NS g.root-servers.net.
. 6215 IN NS h.root-servers.net.
. 6215 IN NS i.root-servers.net.
. 6215 IN NS j.root-servers.net.
. 6215 IN NS k.root-servers.net.
. 6215 IN NS l.root-servers.net.
. 6215 IN NS m.root-servers.net.
. 6215 IN RRSIG NS 8 0 518400 20181227050000 20181214040000 2134 . ak8bdqWZVM0F3vX2ByRRJurV2xD2H/F1cS3SzW/eyi9Gq8p6Z3cwirvV HTmuOfgg9zEEzYId5UBiHqF8OoI1iHI5hsQ0dQ+N2oKvlYwIrMahka/9 TYnZ7w6AmrJO8k+Upk5MPcSKrUg+mUILBPLEex1byP+jhlnCcjxyiJrZ TjNEZQ83D5lE7UW1bohKwnNfFdkD+scNcfJP2RJYyj+dNnzilbunY6Gc Prk6ufJyMBrQ0QGJWADFaIzKPhBUxdmi/Yi7Z/ARXNmyrtlz20IZx+q7 QrI4GL4urVlETvMWZiM1vZZ3KHof+A2Qdyjl3Az/jPQqaxk0kh4M16AY bDOzmg==
;; Received 717 bytes from 1.1.1.1#53(1.1.1.1) in 38 ms

td. 172800 IN NS ns1.nic.td.
td. 172800 IN NS ns-td.nic.fr.
td. 172800 IN NS ns-td.afrinic.net.
td. 86400 IN NSEC tdk. NS RRSIG NSEC
td. 86400 IN RRSIG NSEC 8 1 86400 20181227050000 20181214040000 2134 . l/39sOYlZSMog9p04Gp4roeymGHcagUyKwf1rh6U07XuhFizJ4kquch0 0CYDZo7ZetKI419BB3Nqm2wgFtgUopemXOg1uSSHB/uVMhykyQy9QWo1 jUgzahXr0/1WOqpIrTBYG1aj0w6/yUYj7/gnX1w3NXnQsnFOwQkus8zX qd9d+bclwTi3gd50LVkYk1kN/BxtQnyYJvghlVhxMCj7W9U+8wP5iphb tCQc5RJYIR7WyrQpnAIeuxmTx3cDawJFzM5uXOBN0w1V4v6iHDZpzlL7 O/5bWPpHPTDiUvt6Yc80zKwQ21q/5JxtkVGCsaSDFbBHdj3Z4UaNEPHv M5Z3VA==
;; Received 533 bytes from 193.0.14.129#53(k.root-servers.net) in 141 ms

hotels.td. 86400 IN NS gwen.ns.cloudflare.com.
hotels.td. 86400 IN NS lymn.ns.cloudflare.com.
couldn’t get address for ‘lymn.ns.cloudflare.com’: not found
;; Received 121 bytes from 192.134.0.49#53(ns-td.nic.fr) in 122 ms

hotels.td. 86400 IN NS gwen.ns.cloudflare.com.
hotels.td. 86400 IN NS lynn.ns.cloudflare.com.
;; Received 93 bytes from 2400:cb00:2049:1::adf5:3aa0#53(gwen.ns.cloudflare.com) in 12 ms


#10

You can see the actual delegation using this web based dig query

nslookup won’t show the issue here because gwen.ns.cloudflare.com is valid, and when you ask that server you get the correct answer (showing gwen and lynn), but Cloudflare is checking the delegation.


#11

Great dig resource, thanks for linking.
Iv asked my registry to update the NS, but it is a manual process, so may take a few days.

Thanks for your help


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.