Nameservers not updating and WHOIS lookup not working

I am setting up the NameServers for my domain but after over 24 hours it still seems to say there were non CloudFlare NameServers found although the SameServers i set are just the ones it told me to use on the dashboard page. After diagnosing here is what appeared about the name servers:

Check nameservers
Are the Cloudflare nameservers configured correctly in the site?
non_cloudflare_nameservers
Non-Cloudflare nameservers found

Another thing is that if i check the ICANN lookup it will tell me the folowing:

No registry RDAP server was identified for this domain. Attempting lookup using WHOIS service.
Failed to perform lookup using WHOIS service: TLD_NOT_FOUND.

Something i should add is that I am new to using CloudFlare so it`s probably my mistake :confused:
Thanks in advance

Is this a new domain, @caldeira? https://www.whatsmydns.net/ shows one cloudflare name server returned from three locations, but I see an nxdomain issue when I visit the site and it’s still showing as pending name server change in our system. When done correctly, this change can take up to 24 hours to be seen, if it’s been more time than that, I suspect the change was not done correctly.

I :search: for nxdomain #CommunityTip and found

I suspect it’s quick fix 1 or 2 in the above tip. But, you may want to contact your registrar and verify they removed all non-cloudflare name servers and that you’ve added both of the name servers shown on your DNS tab.

What’s the domain?

Hello! The domain is in fact new. As for the quick fixes, if I see the NameServer settings on the domain provider it has the correct NameServers. I am not sure if it was the full 24 hours but I will probably check everything and make sure to wait at least 24 hours. Might aswell contact the registar as you said and check with them.
Thanks for your help!

To anwser your question @sdayman the domain is magiclandnetwork.ml

.ml’s WHOIS system is not running so well at the moment. And DNSchecker.org isn’t getting good responses back for your domain. No SOA, and very little NS…just a single one from a few locations.

I suggest you contact your registrar to see if they can get better results than Hover, DNSchecker, dot.ml, etc.

1 Like

You simply have a broken nameserver setup.

Your nameservers are kai.ns.cloudflare.com and anita.ns.cloudflare.com, and you only have one set kai.ns.cloudfare.com and that one has a typo.

1 Like

I had originally copy pasted but then I retypes that one and apparently I did type it wrong, I have now fixed it but what do you mean by “you only have one set”? there appear both NameServers although one had a typo

Post a screenshot.


I have meanwhile created a new domain, like the one before but ending in .tk and it worked fine so I assume it was just the typo on the NameServer of the .ml domain

That’s not what the registry provides

nslookup -type=ns magiclandnetwork.ml a.ns.ml
Server:  UnKnown
Address:  185.21.168.1

magiclandnetwork.ml     nameserver = kai.ns.cloudflare.com

Try removing everything and setting it up from scratch. Otherwise contact your registrar for clarification.

This topic was automatically closed after 31 days. New replies are no longer allowed.