Nameservers not updated in cloudflare after 1 week

Hello, My domain is not reflected in Cloudflare, it persists in “Pending nameserver update”.

The official whois of the TLD tells me the correct nameservers assigned to my Cloudflare account, It was not a typo.

I tried deleting the domain from my account and adding it back, but the problem persists.

Any suggestions?

This probably changed the set of assigned name servers. Do check they are still the same and never keep name servers for Cloudflare after deleting a zone.

Could you share your domain name?

Yes, they are still the same
The domain is

If they are and, are you sure you have a plan configured in the Cloudflare dashboard? I have seen a few issues like that…

Yes, Free Plan.
The DNS are correct, the nameservers too, but Cloudflare is still “Pending Nameserver Update

The parent registry (e.g. .mx’s name servers) responds NXDOMAIN for, indicating that the domain does not exist in the DNS system.

A domain WHOIS does unfortunately not reveal any state.

However, the pattern is very consistent with a domain name that may have been suspended from the domain registry.

I would therefore suggest you to contact your domain registrar, asking them for an explanation on why the domain name isn’t being published in the DNS, so that they can troubleshoot and/or eventually escalate things up the chain towards the MX registry.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.