Nameservers error -DNS

Goodmorning, I’ve been having problems with my ovh dominium for a month.
in the “DNS server” section I’ve sected the nameservers that Cloudflare gave me but I’ve always received this error:
“DNS zone validation failed, at leave one of your nameservers is not resolved. please verify your DNS”

Since it’s a .it dominum i got it validated in the italian register.
Waiting for your response.

*domain

What is the domain and what nameservers were you assigned?

Domain: eptanisa it
nameservers: frida ns Cloudflare com and logan ns Cloudflare com

(I can’t put the “.” so I replaced with spaces)

You haven’t set them at your registrar…

I still see them as:

Nameservers
  dns200.anycast.me
  ns200.anycast.me

Go change them at your registrar (OVH).

I have been made to notice this might be your issue, too.

You might need to set them up like this, for example (there are 3 IPs for each NS+A/AAAA combination, you can chose whatever DNS returns).

NS IPv6 IPv4
frida.ns.cloudflare.com. 2606:4700:50:0:0:0:a29f:2689 162.159.38.137
logan.ns.cloudflare.com. 2606:4700:58:0:0:0:adf5:3bc6 108.162.193.198

These are anycasts because I bought “DNS anycast” so by default they are set. Do you think this is the problem?

If you want to use Cloudflare you need to set Cloudflare Nameservers, if you don’t Cloudflare won’t work.

Ho visto che sei italiano:
Quindi tu mi consigli di disattivare anycast DNS e usare esclusivamente quelli di Cloudflare?

Assolutamente si, o usi il set di OVH o quello di Cloudflare, non puoi usarli assieme.

1 Like

Perfetto, provo e ti faccio sapere! Grazie mille

1 Like

Buongiorno, ho contattato nuovamente OVH e anche nic.it:

A quanto pare il problema il problema è dato da:
SOAMasterCompareTest (mi è stato detto d’impostare il nameserver 1 come SOA, contatterò OVH per far ciò)
NSCompareTest
MXCompareTest
MXRecordIsPresentTest

A quest’ultimi tre personalmente non ho trovato una soluzione.
Per la verifica su nic ho utilizzato i nameserver allegati come immagine.


Questa invece è la configurazione di Cloudflare

Piccolo aggiornamento: sono riuscito a risolvere tutti gli errori tranne NSCompareTest e SOAMasterCompareTest

Qui non mi hai ascoltato…

Devi eliminare quelli vecchi di OVH, lasciando solo quelli di Cloudflare.

Dovrebbe risolvere entrambe le cose, ma il NIC .it potrebbe anche richiedere un IP assegnato a ogni NS (prova solo se non funziona senza, mi raccomando).


Elimina i record NS anche qui. Il resto va bene.

Perfetto, grazie mille!