Nameservers aren´t being recognized

nameservers

#1

Hello,

My name is Vitória and I recently bought a domain which I promptly associated with a Cloudfare account. I was then given some new nameservers.

However, I had some problems with that account and I lost access to ti. I created a new one. As a result, I had to change my nameservers as well. However, know I can´t connect my website to the new nameservers that were given to me. They always point to the new ones.

I hope you can help me.

Thanks


Added CloudFlare Nameservers to registar but they change and domain stops working
#2

Whats the domain and which nameservers were you handed?


#3

My domain is www.imoppi.pt.

First I was given the nameservers:

jade.ns.cloudflare.com
wesley.ns.cloudflare.com

Then, they gave me this ones but my register says that it still points to the previous ones. Which means that it wasn´t updated by Cloudfare for some reason.

abby.ns.cloudflare.com
west.ns.cloudflare.com


#4

According to Cloudflare’s nameservers it still should be jade and wesley. jade and wesley was from the first account I presume, right? But you dont have access to that anymore?! If abby and west is what is listed under the new, current account I’d change nameservers to these values and once Cloudflare verified domain it should show up with the right nameservers under the new account.


#5

The thing is, the website were the domain is registered says that they can´t change to these new nameservers and, when they try, it always changes back to the old ones.

Which, according to them, shows that Cloudfare still indicates to the old nameservers and the new ones aren´t being recognized.

Thanks!


#6

Is that dominios[dot]pt? Why do they say they cant change it, respectively why does it change back? Nameservers do not magically change back, particularly as they are the authoritative source.

Cloudflare still lists the previous nameservers as the domain is still connected to the old account with those nameservers. If you want it to switch to the new account you’ll have to change the nameservers.


#7

Hello,

Yes, it is dominios[dot]pt.

I already asked Cloudfare to recheck the nameservers in order to connect the new ones. But so far nothing happened… Do I will have to wait?

Thanks a lot for helping.


#8

I presume you rechecked on the new account, right? Thats wont help much as you’d first need to set the new nameservers.


#9

I did recheck, yes.

Sorry, but what do you mean by set the new nameservers? Anyway I can do that by myself?


#10

You said the new account lists abby and west, right? These are the nameservers you need to set. Whether you can do this yourself or need your registrar depends on how much control you have. Can you log into the control panel of your registrar and change the nameservers?


#11

I can, in my registrar website, however when I try to set the new ones there it does not allow me to save them. I don´t know why, I already asked the support to help me and they said what I previously told you: that they can´t do anything because Cloudfare still assumes those old (jade and wesley) nameservers as those configurated to this domain.

And, of course, they told that I needed to ask Cloudfare to “validate” these new nameservers.


#12

Alright, different approach. Is there any way you can get access to your old Cloudflare account? That would solve the issue too.


#13

Can you ask the registrar if they can override the validation? Cloudflare isn’t asking you to do anything that’s technically impossible. It’s just unusual, and usually a mistake, and the registrar or the TLD is doing extra validation and blocking it.


#14

Well,

I just tried again to talk with the registar and they just insist with the fact that somehow old nameservers are still associated with this domain.

However, I do have a new Imoppi.pt account in Cloudfare and they gave me these new nameservers. I also tried to insert the website in the DNS.pt (association which manages all .pt TLDs) and they show the domain has being associated with the old cloudfares nameservers.

I really don´t know what to do anymore, as I lost all my access to the old accounts.


#15

They are technically not wrong, but that is exactly what you want to do. Change those old new nameservers to the new ones you were given by Cloudflare. At this point I really dont know what to suggest, as it usually shouldnt be a problem at all to associate a new pair of nameservers with a domain. If you registrar refuses to do so, you could probably only talk to the .pt registry directly and/or transfer your domain to another registrar. Maybe point your registrar to this thread, so they understand what the issue is.

It seems they insist on the current nameservers, as Cloudflare still announces them, however Cloudflare will change that announcment only when you actually changed the nameservers and Cloudflare can verify that change. It seems to be a bit of the chicken and egg problem, which could be easily solved by your registrar however.