Nameservers and IP propagating

I’m still experiencing issues with my website where the most updated version of the site is not showing on desktop or mobile.
The home page is studenttraveltips.co.uk (image 1) has the issue. the actual updated version you can only see on studenttraveltips.co.uk/?nocache (image 2). This suggests it’s NOT an issue with Elementor Pro.
I’ve purged all cache and even paused the CloudFare caching settings. I read in a community forum to try and speak to Host so I reached out to GoDaddy and they said that my CloudFare nameservers and IP were propagating. I’m unsure what this means but I think I need to change the IP address on CloudFare and then the issue will be solved once and for all.
Many of the recent changes I’ve made such as the menu bar on the home page aren’t updating and don’t appear on the phone. The red text seen on the page still appears. I deleted this over a week ago.


If this is something that can be helped by the community, please let me know.

Alfie

That website is not proxied by Cloudflare. Are you still having problems?

Judging by your screenshot and what I see on your site, the answer is Yes. What I see is coming directly from your server at AWS.

Oh…you’re using Ezoic. That would explain the difficulties you’re having. Please contact them to for assistance.

1 Like

2 possible causes

  1. Misconfigured DNS records (such as the A or CNAME record)

  2. A redirect rule set in a firewall rule

To check for misconfigured DNS records

  1. Login to your Cloudflare account

  2. Click the domain for http://studenttraveltips.co.uk/

  3. Click the “DNS” tab

  4. Check the DNS records (preferably the A and CNAME records)

How to know if they are misconfigured

If you have your A and/or CNAME record (or any DNS record for that matter) set to http://studenttraveltips.co.uk/?nocache then change it to http://studenttraveltips.co.uk/ OR (if possible) set the DNS record to “DNS only” (grey cloud)!

To check for redirect rules

  1. Login to your Cloudflare account

  2. Click the domain for http://studenttraveltips.co.uk/

  3. Click the “Rules” tab

  4. Check for page rules, if you have a redirect it will look like this (for a 301 redirect)

It may also look like this if you have a 302 redirect set

If either of these are true, click the green icon to disable or deactivate the rule! (or the “X” to delete it)

I hope this helps!

Hi there,

I can confirm that there wasn’t the DNS as /?nocache. It is and will stay as studenttraveltips.co.uk

The rules aren’t as you’ve put them. Currently they are like this:


i have disabled Ezoic. Thanks sdayman. Hopefully this will help.

Alfie

2 Likes

Other than clicking ‘Remove Cloudfare integration’ on Ezoic - do I need to change DNS settings or is that it and i’ll now just wait?

It’s still showing your origin IP instead of a Cloudflare IP address. Do you have Cloudflare paused? You would see this:

I’ve unpaused it. It was paused because of the caching issue, that we’ve spoken of recently. So now, CloudFare is resumed, Ezoic is unintegrated and hopefully it’ll improve. Anything else?

It works again! Thank you so much for your help. The problem must have been Ezoic. Is that a definite no go for monetisation then?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.