Named Tunnel gives empty page

Hi I tried to configure a tunnel from my localhost to my own domain.

  1. Already setup my domain in Cloudflare successfully
  2. Already configured named tunnel successfully

However when I launch my tunnel from http:localhost it shows me an empty page (even though the favicons and title are rightly loaded). The same page on localhost works totally fine.

This is the log I get from launching my tunnel. I’m quite unsure how to fix the --origin-ca-pool error as I’m a pretty newbie to this

Blockquote

2022-10-06T05:50:05Z INF Starting tunnel tunnelID=15e8ae3e-561c-4ff4-8afc-07b5ac3a9bcc
2022-10-06T05:50:05Z INF Version 2022.10.0
2022-10-06T05:50:05Z INF GOOS: windows, GOVersion: go1.19, GoArch: amd64
2022-10-06T05:50:05Z INF cloudflared will not automatically update on Windows systems.
2022-10-06T05:50:05Z INF Generated Connector ID: 22651d3b-4f85-4cc9-ad2a-a01d7978e8bd
2022-10-06T05:50:05Z INF Initial protocol quic
2022-10-06T05:50:05Z INF ICMP proxy will use 192.168.10.145 as source for IPv4
2022-10-06T05:50:05Z INF ICMP proxy will use 2406:3003:2007:27f2:11ca:1701:b242:1282 in zone Wi-Fi as source for IPv6
2022-10-06T05:50:05Z INF cloudflared does not support loading the system root certificate pool on Windows. Please use --origin-ca-pool to specify the path to the certificate pool
2022-10-06T05:50:06Z INF Connection 5ee6d114-d693-475d-8df5-80e6a31f0b66 registered connIndex=0 ip=198.41.200.193 location=SIN
2022-10-06T05:50:07Z INF Connection 488cb741-ad38-4c2d-abc0-c2cd354c1259 registered connIndex=1 ip=198.41.192.37 location=NRT
2022-10-06T05:50:08Z INF Connection eca3fdbe-d6d2-4194-b75f-05199c71ac27 registered connIndex=2 ip=198.41.200.23 location=SIN
2022-10-06T05:50:09Z INF Connection 3cb4e2c9-62a2-450f-8371-8c61965f32c9 registered connIndex=3 ip=198.41.192.47 location=NRT

Here is my config yaml file

tunnel : 15e8ae3e-561c-4ff4-8afc-07b5ac3a9bcc
credentials-file : C:\Users\Razer.cloudflared\15e8ae3e-561c-4ff4-8afc-07b5ac3a9bcc.json

ingress:

Example of a request over TCP:

  • hostname: my host
    service: localhost:6006

Example of a rule responding to traffic with an HTTP status:

  • service: http_status:404

Any help would be appreciated. The same exact setup was working fine in September 2022 (a week ago) but doesnt work now

Hi, welcome to the community.

Is there anything abnormal in your browsers devtools on this page, for example the js console or the network logs? Are you able to grab the status code for the request and does it return the correct html if you view the page source or curl the public url yourself?

That warning is only relevant if you have an ingress origin that uses https against the origin, yours uses http so this warning about ca pools can be safely ignored.

Are you able to test downgrading cloudflared to the version you used back then and trying the tunnel with that? You probably would need to uninstall your current version and then install a past version from github releases: Releases · cloudflare/cloudflared · GitHub

  1. I am able to get the raw HTML of my page using curl. Even ping works fine but the browser doesnt display my page

  2. I tried upgrading cloudflared earlier today and the same issue exists both before and after version upgrade