Namechep advises Cloudflare DNS for https redirect DEBACLE for Google Sites

On Namecheap registrar’s advise to redirect naked domain and https requests, NS was set up on cloudflare from Namecheap. Cloudflare auto config has not worked and the site is now completely down with no tech support from Cloudflare, whereas all requests except https were completed successfully via www.humus.io to https://sites.google.com/humus.io/ on namecheap dns. Now the dysfunction ensues among lockin players Cloudflare, Goolgle and Namecheap

I’m not quite sure what you are saying, but your site is giving “too many redirects”…
https://cf.sjr.org.uk/tools/check?3c41de35ad364cada0896c8123f7da1f#connection-server-https

Check your SSL/TLS setting is set to “Full (strict)” in your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

1 Like

thanks srj …I’ll ck but someone from Cloudflare, Namecheap, or Google who already knows where to click would be prefered.

1 Like

thanks @epic.network
set Full Strict and enabled DNSSEC
per @sjr
set A Record to 192.0.2.1 per link posted yesterday
CNAME | www | ghs.googlehosted.com (is per google)
srj ck today shows redirect to https naked and not to CNAME custom domain on google sites:

propagation is complete but seems logically (technically?) easier to ditch the www per google and redirect or alias directly to gsite with masking?

don’t know about seo but google seems to be in absolute control of what happens in that regard anyway, across all devices

(and me, myself and I must be on something else for a few hours again now)

the only domain schema/syntax that currently works to gsite is https www domain

objective: anything DOMAIN or +/- HTTP or HTTPS with or without WWW lands at HTTPS/WWW/DOMAIN

301 static redirect all traffic to www.domain only redirects to a non existent subdirectory of same i.e., https://www.domain/www.domain

It appears dns records need to change but I do not want 3 days of further issues, considering Cloudflare page rules are deprecated and the general lack of precise instructions in Cloudflare docs.

Current dns records:

thanks @epic.network @sjr et al

Make sure that the target URL in your redirect begins with the scheme, e.g. https://, and you will avoid being sent to an invalid relative URL.

nope, pointing to https:// www.domain returns “The page isn’t redirecting properly” and also breaks the only two gsite urls that do resolve, e.g., https:// www.domain

And https:// sites. google. com/humus.io/humus

Isn’t this supposed to be resolved by the orginal HTTP/HTTPS server host (google) and not Cloudflare DNS ?

@epic.network @sjr

The solution on Redirect Rule, following all of the above, is using “Custom filter expression” option NOT “All incoming requests” option.

This is usually indicative of the use of the insecure Flexible encryption mode. Make sure that you are using Full (strict).

@epic.network per above, yes, Full (strict)

key was on Redirect Rule is using “Custom filter expression” option NOT “All incoming requests” option, i.e., hostname > static URL > 301

Is it working correctly for you now? I am not seeing any problems loading your site.

yes, glad I didn’t change dns record… shown as solution above “Redirect naked…”

It would have been helpful to know that the solution was definitely with Cloudflare and not Google in that both custom and gsite urls were working prior to pointing NS to Cloudflare from Namecheap.