Name Server still updating after 4 days

Hey there :slight_smile:

I changed the nameserver of my website. But the cloudflare admin panel shows me that the nameserver change is still being checked after a few couple of days. I am bit confused cause I also changed from ‘http’ to ‘https’ in wordpress admin panel. Maybe somebody of u have an idea what to do. And another question would be: If the website finally get the ssl certifaction, the change in wordpress settings from ‘http’ to ‘https’ will be fine or did I crashed all farther steps cause of this mistake?

The Domain Name is:
http://www.joeysander.ml/

Regards
Joey

I have checked and your domain nameservers does not point to Cloudflare ones. Where did you changed them?

Moreover, joeysander.ml got me “This domain is not registered.”
If the domain is recently registered, maybe it needs to pass some time to make it available to the public?

Furthermore, regarding the nameservers you should change the nameservers at your domain registar:

1 Like

You would get some other issue like mixed-content (possible), or some SSL error if so.

Possibly it would work, but if you encounter any issues, then you would have to check the settings for an SSL at for your domain at Cloudflare dashboard.
Moreover, possible way you would have to enable “Always HTTP” and “Automatic HTTPS redirection”.

Due to not knowing if you have had an SSL certificate already installed for your domain/sub-domain at your host/origin, I cannot write with 100% if there would be a need to investigate more and fix something upfront - which could be the “SSL tab” and the option like “Full SSL”.

Other case is where you would also need to rewrite your HTTP to HTTPS at your WordPress database (using either a WordPress plugin like Better Search Replace) - due to possible mixed-content errors which could show up.

1 Like

For starters, Cloudflare won’t provide that. You first need a valid certificate on your server. If you don’t have that you don’t need to look further into Cloudflare until you fixed that.

2 Likes

Hey, thanks for your help. The nameserver point to Cloudflare ones now. The Domain should be registered aswell and the nameservers changed on “freenom” where I got the Domain from. The website was also accessible a few minutes ago. But it is not accessible anymore. The error is called “ERR_TOO_MANY_REDIRECTS”. Do you have an Idea how to fix this?

InfinityFree is the host of my webseite. There is the Info:
Your domain name is using Cloudflare nameservers, so you need to add the CNAME records to Cloudflare. Please make sure the records are set to DNS Only (or they won’t work).

Regards
Joey

Is your SSL encryption mode Flexible?

1 Like

Hey, I am not sure :3 I used this plugin for the ssl:

and the ssl certifacte itself is coming from “InfinityFree”

Regards

Make sure your encryption mode at https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls is “Full strict”.

1 Like

I get this error on the website after changing it from flexible to full strict

Then your SSL certificate is broken and you need to fix that first.

1 Like

You have to access your hosting control panel and there generate a free or paid SSL certificate. Then activate the Strict option of CloudFlare.
Hire more info about SSL on cPanel

1 Like

This topic was automatically closed after 29 days. New replies are no longer allowed.