Naked URL not Forwarding - Wrong Page Rules?

pagerules

#1

Hi,

I know this has been discussed before and I’ve configured it but I am failing to be able to have my site redirect without the “www”


#2

You don’t have a DNS entry for myconsultingoffer.org

Go to your Cloudflare DNS settings and add an entry for @ (or just type in the naked domain) and make it look like your www entry. The Page Rule will catch visitors to the naked domain and forward them to the www.

You also don’t need Rule #3 since Rule #1 will pick up http and https.
You can skip Rule #2 if you use the Cloudflare Crypto settings setting for "Always Use HTTPS. That is…if you don’t have subdomains that don’t use HTTPS. But who does that these days, eh? :grinning:


#4

Thank you - I see you around a lot and you are just a great value to our community.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.