Naked domain redirect not working

When typing in example.com, I get a DNS_PROBE_FINISHED_NXDOMAIN error. www.example.com works. I’ve scoured every single forum on here and set up a page redirect (examplecom/* 302 to www.examplecom/$1) (examplecom without the . because I can’t post links) and proxied the ip.
Please help me!!
Thank you in advance :slight_smile:

What is the domain? Can you show a screenshot of your redirect/page rule?

Of course. The domain is www.aspatriotenergy.com
Here is the screenshot of each rule


Thank you for getting back to me!

You need a DNS record for aspatriotenergy.com so it resolves to Cloudflare…
https://cf.sjr.org.uk/tools/check?c9dabb82dba84838aa90afe544705a82#dns

Add a dummy proxied DNS record for the domain (@) or subdomains as A 192.0.2.1 or AAAA 100:: as it is just for redirect.

Then choose if you want a redirect rule or page rule and delete the other to avoid confusion.

The page rule looks ok.

If using the redirect rule (preferred as page rules will be deprecated at some point in the future), then change URL Full equals... to hostname equals aspatriotenery.com and the redirect target to https://www.aspatriotenergy.com. If you want to pass the path in the redirect, then copy this example to make the redirect dynamic…

1 Like

Thank you for your quick reply! I think I already have a proxied DNS… here is a screenshot of my records.

I just changed the old ip to the new dummy one (192.0.2.1). It still doesn’t seem to work. Let me know!!

You have entered for a wildcard (*) subdomain, but you want to redirect from the apex domain (which won’t be matched by the wildcard) so you need to create a record for @ which will show as aspatriotenergy.com in the dashboard after you have entered it.

1 Like

So I just change the record name to aspatriotenergy.com? How do I show it as aspatriotenergy.com? Do I leave the name blank?
Edit: never mind I got it. The name should be @. I think it works now. Thank you so much!

1 Like

Edit the DNS record. Delete the * and enter just @ instead.

2 Likes

Got it. Thank you so much! It worked!!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.