Naked domain goes to HTTP, not HTTPS (but "www." works fine)

Domain name: foammarkerkits. com
Actual web address/hosting: foammarkers.000webhostapp. com

Putting “www.foammarkerkits. com” in the address field goes to “https://www.foammarkerkits. com” in all three browsers (Firefox/Chrome/Edge). All fine, all good.

However, putting “foammarkerkits. com” (without the “www.” bit), while still going to the website, gives the little red padlock/“not secure” warning in the address field.

As this is a business website, it would be good if that didn’t happen when customers visit.

Cloudflare settings are as follows:

DNS
CNAME foammarkerkits.com foammarkers.000webhostapp.com Auto Proxied
CNAME www foammarkers.000webhostapp.com Auto Proxied

SSL/TLS
SSL/TLS encryption mode is Full
Always Use HTTPS
On

Page Rules
Automatic HTTPS Rewrites
On

Any help would be much appreciated.

Without ‘www’, I got redirected to HTTPS, which loaded securely.

1 Like

If you want it to automatically redirect to a website, simply create a new page rule then enter the 3xx redirection code. Notice: Unless you have the site active on cloudflare, page rules (among other things) won’t be applied until the site is active on cloudflare

Thanks for the replies. Have set redirection under page rules accordingly:

*foammarkerkits.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.foammarkerkits.com)

…but (despite clearing browser caches, etc) naked URL is still showing as not secure in browsers.

Firefox: 1
Chrome: 2

Never mind, probably something at my end, will persevere.

UPDATE: Website is finally doing what it’s supposed to, seems like it might’ve just taken a day or two for all the settings to take effect.

Just for the sake of good order, unless you fixed the certificate on your server you still have an insecure site because of the broken/non-existent server certificate.

This topic was automatically closed after 29 days. New replies are no longer allowed.