Naked domain doesn't redirect even after setting page rules

I am trying to set up a grocery website for my friend who will be providing home delivery of grocery from his shop to people in his village.

Our website doesn’t redirect when we enter http:// tkart.cf or https:// tkart.cf

Sometimes many users might simply enter the naked domain part in his/her browser, so we want both the URLs mentioned above to redirect to https:// www.tkart.cf

We are using Google Sites and Freenom domain for our website.

Settings used are as follows:

  1. DNS Management

CNAME www ghs.googlehosted.com Auto Proxied

  1. SSL/TLS

SSL/TLS encryption mode is Full (strict)

Always Use HTTPS : ON

HSTS :
Status: On
Max-Age: 6 months (Recommended)
Include subdomains: On
Preload: On

Minimum TLS Version : TLS 1.0

Opportunistic Encryption: ON

TLS 1.3 : ON

Automatic HTTPS Rewrites : ON

  1. Page rule

If the URL matches :

tkart.cf/*
I used http:// tkart.cf/* as well

Then the settings are:

Forwarding URL 301-Parmanent Redirect
https://www.tkart.cf/$1

The error that we receive on browser is as below:

tkart.cf ’s server IP address could not be found.

You don’t have any DNS record for your naked domain.

1 Like

Any workaround? :roll_eyes:

Creating the record? :slight_smile:

1 Like

There’s a dedicated tutorial under #Tutorials.

1 Like

I am wondering what record I would put under the naked domain part.
Because Google sites don’t have things like A records.

It worked after putting A records 216.239.32.21, 216.239.34.21, and so on which are used for blogger and retaining the existing page rule. Thanks :slight_smile:

This topic was automatically closed after 31 days. New replies are no longer allowed.