`mysite.com` requires "/" to resolve to `www.mysite.com`

Cloudflare is registrar, email (MX) is over at Ionos
https rewrite is turned on–

mysite.com will resolve to 404(can’t find url)

Once forward slash is added mysite.com/ will then resolve to https://www.mysite.com/

How can records be adjusted so that when ONLY mysite.com entered site resolves correctly?
e.g. User enter mysite.com and then resolves to www.mysite.com

Current Records:
Type Name Content ProxyStatus
A mysite.com 34.xxx.xx.x DNS only
CNAME * funnels.msgsnd.com DNS only
MX mysite.com mx01.ionos.com DNS only

URL required
Enter destination URL (required)

The domain mysite.com is not using Cloudflare.

dig ns mysite.com +short

If you intended that real domain as a placeholder for your own secret domain, the reserved names, such as example.com are more suitable.

Any redirection of your example.com apex name is happening at your origin server. Your Page Rule cannot have any effect because your record is set to :grey: DNS Only. Page Rules are handled on the Cloudflare proxy which requires the name be set to :orange: before the rule can be applied.

Oops…Ok, will use example.com in future.

I am trying to get it working with DNS Only for now.

Based on the records above, example.com is not resolving to www.example.com
In the CNAME record there is a * to allow sub domains.

What records do i need to have?

When the A record for example.com is set to :grey: DNS Only, the Page Rule that you have configure to redirect example.com/* to https://www.example.com cannot do anything. This means that the redirection that is happening now is being done by whatever is running on your origin server.

If you want to keept it set to :grey:, you will have to consult the appropriate resources for your origin site to see how to handle that redirect on whatever platform you are using at the 34.X.X.X.

If you turn on the :orange: proxy, your Page Rule should handle the redirect that you want.

Regardless of where you handle the redirect, it should work with the DNS records you currently have.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.