My worker doesn't trigger on custom route anymore

Hi,
I’ve been using proxy workers for subdomains rewriting (typical /blog transparent redirection to blog. subdomain) and since the 23rd, it stopped worked suddenly.

I’m proxying the URI /questions* into a separate operated server and while in the worker edit mode, I can see that fetching the example URI /questions/build/script.js on either the .dev domain or the custom route will work; doing so from outside with a regular curl will only work on the .dev domain and will 404 on the custom route.
(full URL being https://io-redirect-questions.mjb-blog.workers.dev/questions/build/script.js and https://www.monjardinbio.com/questions/build/script.js )
It used to work for weeks and no change were made on my side afaik.

I tried to disable/enable workers.dev mapping, change the custom route to this specific URL and back to the previous wildcard route. I have a full SSL connection to the origin server (since it was mentioned in a similar yet different recent topic about worker routing).

Any idea on what could go wrong and how I could fix it?

Thanks in advance.

@MoreHelp ticket #2241594
Unfortunately the problem persists and no answer nor hint could be provided here.