My website's subdomain isn't working

Hello everyone! I created a subdomain and it’s been down since then, many hours have passed and I’m suspecting Cloudflare might have something to do with that (I didn’t touch the dns records because I’m never sure what to do, the main site is protected and I thought that Cloudflare would protect the subdomain too, is that correct?). I checked on dnschecker.org and it’s certainly down. Any thoughts, ideas or suggestions?

Thank you guys very much in advance!

You need to add the subdomain to the DNS records or it can’t be resolved…
https://cf.sjr.org.uk/tools/check?bd53fcecb06c45788100c328c12f89d2#dns

1 Like

Hi @sjr , thank you very much for your kind response. I did what you and the website suggested, and the status changed to green. But twhen I visit my website I still can’t see it, it says ERR_TOO_MANY_REDIRECTS :man_shrugging:t4:

These are the records I added: DNS records.jpg - Google Drive

Make sure your SSL/TLS setting is set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Although it seems you have both a redirect from http->https and a redirect from https->http. You’ll need to find them and remove one.
https://cf.sjr.org.uk/tools/check?3318a414907344758f66ffe70f7d2616#connection-worker-http

Note also you won’t be able to use the proxy with www.testeando unless using the Advanced Certificate Manager as this is a second-level subdomain and Universal SSL only covers the apex and first-level subdomains.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.