My website works when 'dns only', inaccessible when proxied

Answer these questions to help the Community help you get started.

What is the domain name?.

Have you searched for an answer?

Please share your search results url: many people have encountered this, no solid or working solution. most have just turned of the proxy, but the whole point is the proxy.

When you tested your domain using the [Cloudflare Diagnostic Center] what were the results?
no clear solution

Describe the issue you are having:
i moved my dns to Cloudflare.
changed the dns in my registrar to Cloudflare.
when the a records are ‘dns only’, the website works as usual.
when changing the proxy status of A records to ‘proxied’, i can’t access the website.

What error message or number are you receiving?
the message is:

This page isn’t working redirected you too many times.

What steps have you taken to resolve the issue?

  1. checked the instruction, all done
  2. cleared cookies, waited some time, hard reload
  3. google the error, checked other people complaing about the same issue. no solution found.

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. go to
  2. see the website is not working.
  3. if you change in Cloudflare to ‘dns only’, it works .

Have you tried from another browser and/or incognito mode?
yes, same results.

What is the SSL mode of your zone? Make sure it is set to Full (strict).


Yes! that solved the issue, thank you so much!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.