My website with www version showing expired ssl certificate

my website with www version showing expired ssl certificate. https://nirbik.com showing new ssl. but https://www.nirbik.com showing expired ssl. please solve this issue. you can check here SSL Certificate Checker - Diagnostic Tool | DigiCert.com

That looks like a bug to me.

You can try and force a redeployment of the certificates by changing the minimum TLS version to TLS 1.2.

https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates

I did. But still not working.

What to do now? :pensive: I disabled cloudflare temporary. Beacuse i am loosing traffic.

You should log a ticket with support. Please post the ticket reference here.

You can try disabling/enabling Universal SSL to force a new cert to be issued. Using the link I posted earlier, go to the bottom of that page and click Disable Universal SSL. Wait 10 minutes, then click that button again to Enable Universal SSL. This should re-issue a new certificate.

As you are no longer :orange: it should be safe to do this.

2 Likes

I tried this many time before.Not working. I think it is a cloudflare system bug. I am already contacted with support team. But they are telling me to post in the cloudflare community. My ticket number is: 2159157

I can see that the www cert is only valid for:

www.nirbik.com
sni.cloudflaressl.com

The other cert is valid for the usual group of domains:

nirbik.com 
*.nirbik.com
sni.cloudflaressl.com

Were you previously on a partial setup, or using a provider like Shopify or Kajabi for www?

1 Like

When you contact support they will send you an automated email. Make sure you read and reply to that email.

1 Like

I’ve used Cloudflare before. Then I deleted the property and created new one. This old expired certificate from deleted property.

Yes i replied that email. And they send me this. Same bot message.

As you deleted the old property, I expect you need a Cloudflare engineer to resolve, which will probably be no sooner than tomorrow.

You could try and purchase an Advanced Certificate if you cannot wait. Based on https://developers.cloudflare.com/ssl/ssl-tls/certificate-and-hostname-priority, the ACM cert might take priority.

Cc @cloonan

1 Like

I need help. Still no solution.

@MoreHelp Please help me.

Can you paste in the last response from Support on Ticket #2159157?

I Didn’t understand. What to paste?

What’s the last thing Support told you on your ticket?

See this.

Hi there!

I’m currently having a look at this as @domjh tagged me. Indeed I can see a different (expired) certificate being delivered on the www of your site. Depending on what I find, we may need to escalate this to our engineering team or maybe a quick manual redeploy is all it needs.

I’ll also reply on the ticket and put it on a higher priority.

Hope that helps :+1:

5 Likes

Thanks. I’m waiting for the solution

1 Like