"My website will only display correctly when Cloudflare caching is set to "Developer."

Any changes made to my website (new image/blogpost) would no longer display on public browsers. The only thing that made the changes visible was purging the entire cache.

I ran across a note which essentially told me put my cache in Development mode, which did allow the changes to be seen. But as I understand it, this bypasses Cloudflare, and seems to defeat the purpose of having this service at all.

Current Cache settings are:
Caching Level - No String Level
Browser Cache TTL - Respect existing headers
Always online - disabled
Development Mode - enabled

Any help would be appreciated.

What’s the domain?

Roymgriffis.com

griff

Roy M. Griffis

Winner, The John Milius Screenwriting Award

Author of By The Hands of Men series and the Cthulhu, Amalgamated series

Homepage: http://roymgriffis.com

Facebook: Roy M. Griffis Storyteller

It looks like it’s still in Development mode, so it’s a little difficult to troubleshoot.

But it looks like you’re using APO (Automated Platform Optimization). Is this true?

I just turned Developer off…didn’t expect a reply so soon.

APO: not sure, I’ve never set it up. Unless it runs by default?

griff

Roy M. Griffis

Winner, The John Milius Screenwriting Award

Author of By The Hands of Men series and the Cthulhu, Amalgamated series

Homepage: http://roymgriffis.com

Facebook: Roy M. Griffis Storyteller

APO is on, yes.

griff

Roy M. Griffis

Winner, The John Milius Screenwriting Award

Author of By The Hands of Men series and the Cthulhu, Amalgamated series

Homepage: http://roymgriffis.com

Facebook: Roy M. Griffis Storyteller

It’s not a default setup. It’s $5/month if you’re on a free plan, and it’s enabled at dash.cloudflare.com under Speed → Optimization.

And It looks like yours is enabled. The catch sometimes is that the Cloudflare Plugin on your site doesn’t always purge all the relevant pages when you make an update.

If APO doesn’t purge the proper pages, you’d have to do it manually at the bottom of the Cloudflare Settings page.

I suspect APO doesn’t recognize your front page as affected by blog updates, and I know others have faced similar issues. I suggest you open a ticket via email to support AT cloudflare DOT com and then post the ticket # here so we can escalate it to someone who can see why APO isn’t purging as expected.

After I blundered into the secret setting page on my Cloudflare plug in, I noticed a button for “Set Defaults for Word Press.”

I hit that…

Things work now.

Who knew?

griff

Roy M. Griffis

Winner, The John Milius Screenwriting Award

Author of By The Hands of Men series and the Cthulhu, Amalgamated series

Homepage: http://roymgriffis.com

Facebook: Roy M. Griffis Storyteller

1 Like

By the way, thanks for responding, dude. You discussion points led me in the right direction. Appreciate your time.

griff

Roy M. Griffis

Winner, The John Milius Screenwriting Award

Author of By The Hands of Men series and the Cthulhu, Amalgamated series

Homepage: http://roymgriffis.com

Facebook: Roy M. Griffis Storyteller

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.