My website refuses to connect over https

Hello. I recently registered a domain with cloudflare, and it appears to be having issues with ssl. I can connect fine over http, however when I switch to using https, it refuses to work. I get the message that it refused to connect. I have universal ssl active, and that’s the only ssl I have. I also have it set to always use https, but it can’t.
The link is http://nibblenerds.com
This works, but if you change it to https, it fails. Any ideas as to what is going on?

That site is currently unproxied, so it is not using Cloudflare.

To have encryption, you need to install an SSL certificate on your server.

If you want to use Cloudflare, you can use an Origin certificate. Otherwise, any publicly trusted certificate (i.e. LetsEncrypt) will work.

If I change my a record to be proxied, the https works fine without installing a certificate, however it now doesn’t let me use ssh. Is there a way to fix this?

It actually does not work fine, you just don’t see a warning anymore. To make your site secure, you need to install the certificate and change the Encryption mode to Full (strict).

Cloudflare offers a way to do this securely, but it is a lot more complex and involves installing software both on your server and your client device:

Alternatively, you could obtain a publicly trusted certificate (like the one from LetsEncrypt I mentioned) and change your DNS settings back to DNS-only.

2 Likes

You can also create an unproxied hostname for SSH access.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.