My website layout appears to have problems after installing Cloudflare

I want to thank everyone in advance for your attention.
I have a WordPress website with an Envato newspaper template. I also have the litespeed cache. However, when I use my dicaappdodia.com website it appears disconfigured, the entire site design is disconfigured.

When I enable developer mode in cloudflare, my site goes back to normal.

What do I need to do to resolve this problem?

I’m seeing resources for ampproject. Does your site have any configuration for AMP? If so, turn it off, then purge cache to see if it fixes the issue.

I’ve already done this, despite needing AMP, as I have a lot of access via cell phone.

But it didn’t do anything, I even left more than 24 for cloudflare to pick up the changes, and nothing.

I’m not clear on how this is possible, because AMP was loading when I viewed the site. If you already turned it off and purged it, I shouldn’t have seen any indications of it.

At this point, I no longer see any references to AMP, but the page redirects several times before loading:

It first loaded an unformatted version of the site:

Then redirects to a formatted version of the site:

Whatever your site is doing is causing that unwanted version to be cached by APO. You’ll either have to disable APO, or fix your site so there’s just the one version of it.

1 Like

Sorry for the lack of knowledge but what is APO and the Cloudflare plugin on Wordpress?


I believe that the response on the website resolved the issue, but the layout still doesn’t load

I found the APO in the Cloudflare settings but the error continues

Apologies. I thought I saw headers from the Cloudflare plugin on your site.

It’s still returning a HIT for the home page, so something is caching your site’s pages, which is not default behavior for Cloudflare.

Your next step would be to track down what it is that’s set to cache all the content on the site. It’s either a Page Rule for Cache Everything, or a Cache Rule that’s set to enable Cache for your home page (and other content).

After you make any changes, be sure to Purge Everything to get a fresh start.

I cleaned the cache directly from the server I have hired, checked the plugins, cleaned the cache on Cloudflare and my page still has problems.
And when I put Cloudflare in developer mode, everything works perfectly.

The home page is still cached. That’s the problem. You need to turn off whatever setting you have that’s doing that. And then purge all cache.

LiteSpeed cache may also be a problem, so I suggest you turn that off for now.

1 Like

Disabling the LiteSpeed cache made all the difference, but now when I click on links to articles on my website it takes time to load.
But the home page alone has made a big difference, thank you very much for your help, support and attention.
But do I keep it disabled or is there some specific configuration between LiteSpeed and Cloudflare?

1 Like

Since you’re still caching HTML at Cloudflare, you can try LiteSpeed’s Instant Click:

https://docs.litespeedtech.com/lscache/lscwp/cache/#instant-click

1 Like

When you talk about still caching HTML, what best way do you suggest to configure it?