My Website Is Redirecting to 127.0.0.1 after opening few pages

I have been using Cloudflare for over a month now, but recently, I have seen this error where my website get redirected to 127.0.0.1 after I open few web pages

Is it something that you’re able to reproduce frequently or just a intermittent issue now & then?

Based on checkings. It happens once in a while. But, since the last hours that I have paused Cloudflare, I haven’t seen the error.

Is it any Cloudflare site or is there a specific domain that it was happening on?

Getting a random, but increasingly common error where the connection is refused and sends users to 127.0.0.1 - Need to fix. URL is https://curchods.com/

➜  ~ curl -sSI https://curchods.com/
HTTP/2 302 
date: Thu, 28 Apr 2022 20:51:49 GMT
content-type: text/html; charset=UTF-8
location: http://127.0.0.1
x-powered-by: PHP/7.4.29
x-powered-by: PleskLin
set-cookie: ppwp_wp_session=675e78d89f4790258b83938d55629592%7C%7C1651180909%7C%7C1651180549; expires=Thu, 28-Apr-2022 21:21:49 GMT; Max-Age=1800; path=/
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=FYArYDa01jPZ3TmemD4kr1yixGe7Ixqx8Q3FnkG69%2FxqUh0cb3A5xVIfb5CUrQ%2FYRDCvv%2Fj1MxnGvtGup81boxliQ4DzCXIbYqd%2BncBOVvbNwUWmoTmTkcnewtaebA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 7032ad97da947511-LHR

I can see your origin’s headers - like x-powered-by - this seems to be sent by your origin/hosting provider itself.

I haven’t been able to replicate this on any other Cloudflare websites.

2 Likes

It was happening to my website https://gadgetstripe.com

I’ve had until curl -sSI https://gadgetstripe.com | grep -m 1 "location"; do : ; done running for a little bit now and haven’t had any output indicating a 301 or 302 is being returned.

However, I was able to replicate it pretty quickly for https://curchods.com/

Your websites seem to share rel="https://api.w.org/" in the link header so maybe there’s a common hosting provider or plugin that’s causing this.

2 Likes

We’ve seen instances of this in the past and I see tickets related to it that show

Correct, Cloudflare would never actually do a redirect to 127.0.0.1/.

Are either of the sites running APO?

1 Like

Hi

I have only received this issue only when I have Cloudflare is turned on

I’ve been fetching your site for more than an hour & didn’t get a single redirect - are you still experiencing this?

1 Like

I have disabled/pause Cloudflare since past hours that might be the reason why you didn’t see the error

I suspect when not paused, we’re serving from cache. Was this happening consistently? If you unpause and purge cache does the issue happen?

Hi Cloonan,

It was happening consistently and I have unpaused and purge cache, this issue still happens

2 Likes

Can you grab a trace the next time you enable cf?

Please I am confused, I dont get what you meant

1 Like

I am sorry, i should have been more clear, https://support.cloudflare.com/hc/en-us/articles/203118044#h_b8cebafd-9243-40e9-9c44-d4b94ccd3a87

If you can share the output here that will help diagnose.

Hello I have done that, the re


sult is attached to this replyPreformatted text

1 Like

Sorry for a late reply. If you use IP WHOIS Lookup - Lookup IP WHOIS Information - WhatIsMyIP.com® you can find out where the connection is dropped, it never reached Cloudflare.

There may be other issues, are you using any third party merchant service for the site? I recall there was something odd when you dig the dns records.

Note for future reference. This is caused by a misconfiguration on your web server directly or sometimes in WordPress. It is not a Cloudflare redirect.

1 Like