My website is not working after switching from Godaddy to Cloudflare

Hello all,

I own a website with ip 3.6.45.68. It is a wordpress site hosted on AWS.

I also own a domain name LIGHTHOUZE.com which was purchased thru Godaddy. I had an A record on Godaddy which was pointing to my website ip. The redirect was working fine. There were only two problems with that.

  1. When it redirected to my website IP, it didn’t mask the IP. I wanted the URL box to show my domain name but it showed the IP.
  2. My website with IP address worked only with http and not https. And with http it shows “Not secure”.

So I decided to fix that by using Cloudflare. I followed the 5 steps that included switching the DNS servers on my Go-daddy account, downloading Flexible SSL pluging on my wordpress site and turning on “Always use HTTPS” on Cloudflare.

After doing all this, the domain stopped working. You can try it. The website is still working with the IP address mentioned at the top.

So my goals is that when users type my domain they see my wordpress site with domain name in the URL and not the IP. Also, I don’ want my users to see the “Not secure” thingy.

Any insights to get to my goals will be really useful. Thank you for taking time to read this.

Two issues here.

  1. It seems like there’s something redirecting back to your IP address. (Webserver config, though i don’t know at the Moment why the cert is valid then)

  2. When I open http://yourip Ican see your WP site, using https:// i get a ‘connection refused’ (Webserver or firewall config)

Check the server or WP config first or ask your host if you don’t know where to look at.

Thank you Mark!
I don’t know much about either php or wp. But I see that on my wp admin page under general settings - I got two fields:

WordPress Address (URL) and Site Address (URL). Both of these are assigned my ip address.
If I change WP Address (URL) to the domain name then I can not access my wp site. So I can not touch that.
Appreciate your trying to help!
Regards,
Kamal

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.