My website is not running properly with JetPack?

My Jetpack is not syncing correctly with cloudflare. I have done asper directed by my webhost manager. following the instructions of this website: Use Cloudflare’s SSL certificate on your site. And did the folloing instructions from the website:

  1. Under the SSL/TLS menu, enable one of Cloudflare’s SSL options.

  2. Wait for the changes to be available on your site.

  3. Install and activate the Cloudflare plugin.

  4. Install the Cloudflare Flexible SSL plugin to avoid running into Redirect loop issues in your dashboard.

  5. In your Cloudflare settings, create a Page Rule to redirect all traffic from HTTP to HTTPS.

I have miss step number 4 and 5 according to the instructions on page:
Use Cloudflare’s SSL certificate on your site.

Because I have no idea where this code suppose to go. Either on Cloudflare or my webhost?

Please help!
This is the code:
Step 4: Enable Administration over SSL (reference) by adding the following to wp-config.php

1
2
3
4
/**
 * Admin over SSL
 */
define('FORCE_SSL_ADMIN', true);

Step 5: Set the port to 443 by adding the following to wp-config.php:

1
2
3
4
/**

  • Set port to 443
    */
    $_SERVER[‘SERVER_PORT’] = 443;

I have done asper directed by my webhost manager. following the instructions of this website: Use Cloudflare’s SSL certificate on your site. And did the folloing instructions from the website:

1 Under the SSL/TLS menu, enable one of Cloudflare’s SSL options.

1 Wait for the changes to be available on your site.

2 Install and activate the Cloudflare plugin.

3 Install the Cloudflare Flexible SSL plugin to avoid running into Redirect loop issues in your dashboard.

6 In your Cloudflare settings, create a Page Rule to redirect all traffic from HTTP to HTTPS.

I have miss step number 4 and 5 according to the instructions on page:
Use Cloudflare’s SSL certificate on your site.

Because I have no idea where this code suppose to go. Either on Cloudflare or my webhost?

Please help!
This is the code:
Step 4: Enable Administration over SSL (reference) by adding the following to wp-config.php

1
2
3
4
/**
 * Admin over SSL
 */
define('FORCE_SSL_ADMIN', true);
...

Step 5: Set the port to 443 by adding the following to wp-config.php:


...

1
2
3
4
/**
* Set port to 443
*/
$_SERVER[‘SERVER_PORT’] = 443;

Before moving to Cloudflare, was your Website working over HTTPS connection?
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Ouch! Please, not the Flexible SSL … it’s causing issues with JetPack and not secure way for your visitor. That’s why JetPack connects to port 80 and asking you to configure port 443.

As far as I have checked, JetPack step-by-step instructions from the linked articles seems to be not secure way and shouldn’t be followed exactly as stated.

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

You might want to whitelist/allow/bypass JetPack at Cloudflare dashboard using Firewall Rules and IP Access Rules:

Therefore, kindly make sure you setup your origin host/server to return the visitor IP just in case:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Other topics about JetPack and Cloudflare :search: :

2 Likes

Hello! Sir. thank you for the elaborated respons. I’m really trying here to make the best of it since all I want istt to make blog post that can be interactive with all social networks. And in reality I haven’t been able to make one single post that can work with Instagram because it alway end up not shoing properly. I’m still new at this website creation think. I first downloaded my Jetpack and still acting up. and then I made a post in my web address that they are coming halfway true.
Example below:
https://prntscr.com/22zt3lx

This is the error I’m still getting from Jetpack:
https://prnt.sc/22x3mxb

This is what my cPanel is telling me:
https://prnt.sc/22z36aa
However I do not know how to setup a Firewall Rule or and IP Access Rule like you said. I have not seen those rules in my Cloudflare panel. I don’t think I have them. :thinking:
https://prnt.sc/22zuwtn.

Would you be kind enough to point me out in the right direction? Thank you!

Few issues:

  1. cPanel screenshot → SSL certificate expired / self-signed (you might need to renew it via AutoSSL), or rather you uploaded and are using Cloudflare Origin CA Certificate into the cPanel? If using Cloudflare Origin CA Certificate, make sure the A www and A domain.com are both proxied :orange: cloud and SSL is set to Full (Strict) SSL in the SSL/TLS tab of the Cloudflare dashboard.
  2. Screenshot from JetPack → May I ask is that official JetPack interface, or rather some “builder” or from some hosting partner/provider?
  3. In terms of whitelisting JetPack IP addresses in Cloudflare Firewall Rules, please make sure to have as follows from below two screenshots

Navigate to Firewall Rules → button Create a Firewall Rule → Add name for it, copy-paste expression from below (or enter values as on the screenshot), select action “Allow” and hit the button “Deploy”

Expression:

  • (ip.src in {122.248.245.244/32 54.217.201.243/32 54.232.116.4/32 192.0.80.0/20 192.0.96.0/20 192.0.112.0/20 195.234.108.0/22})

Not sure, but few possible issues could be with it:

  1. Redirection loops (HTTP<->HTTPS)
  2. Too big image (resolution size)
  3. Too large image size (size in MB)
  4. Not having the OpenGraph meta tags like for image (og:image) defined
  5. Something is preventing Facebook/Instagram to generate a “preview link/image” while sharing a link - maybe Bot Fight Mode if you have got this option enabled at Cloudflare dashboard too?
  6. Request from the plugin/API is being blocked and shown at Cloudflare dashboard → Firewall → Firewall Events if so
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.