My Website is not loading after I updated my nameservers

That message suggests that you are attempting to obtain a certificate in the format of something.*.example.com which is not possible.

You can obtain a wildcard certificate in the format *.something.example.com or *.example.com. You could even get one for *.something.else.example.com. In any case, the wildcard must be the leftmost component of the name.

Additionally, Cloudflare Universal SSL only works one level deep. Any names below that will require paid options at Cloudflare if they are proxied.

For assistance with ACME certificate issuance, the Let’s Encrypt Community is often a useful resource if you are using their certificate authority.

@epic.network @GeorgeAppiah thanks for your update. Now I managed to create SSL certificate on my vm IIS as per attached screenshot, what’s


then next to make my mpsuaedotcom and wwwmpsuaedotcom secure with ssl

In the same way as you’ve currently created a certificate for mps.centralindia.cloudapp.azure.com, you would need to create one for “mpsuae.com” and ``www.mpsuae.com`, as well as any other (sub-)domains, that you want to serve.

You can do it with “mpsuae.com” and “*.mpsuae.com”, to include all fist level sub-domains.

1 Like

@DarkDeviL I have now managed to create 2 certificates one for wwwmpsuaedotcom and one for mpsuaedotcom, both certificates are stored now locally. Whats next step

Moreover, I have received this email from Cloudflare


attached after creation of certificate

The next step would be to install the certificate for the virtual host (“website”) in your web server’s configuration (IIS, according to your previous words).

If you need further instructions for that, I would have to advice you to dig in to the documentation for IIS.

As the last section says, that message is normal when “Certificate Transparency Monitoring” is enabled on your zone.

hi @DarkDeviL I have already ssl installed on IIS, hence how can I install both www and subdomain certificates on IIS again since my DNS settings are on cloudflare now ?

No matter if you ask your server for “mps.centralindia.cloudapp.azure.com”, “mpsuae.com” or “www.mpsuae.com”, it will all result in a presentation of the certificate for “mps.centralindia.cloudapp.azure.com”.

That would indicate that you either haven’t properly installed the newly generated certificate you were notified about by email above, or, alternatively, that you’re running what I would refer to, as a stone age version of IIS, which does not support running multiple secured websites through Server Name Indication (SNI).

The DNS settings (or any other settings) on Cloudflare are not at all relevant to the question about how you can install your certificate, and/or how you can configure your IIS web server.

1 Like

@DarkDeviL @epic.network Thank you all, it works now successfully. Appreciate your support

1 Like

Check nameserver updates, clear browser cache, wait for DNS propagation, verify DNS settings, contact hosting provider, and check for server issues.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.