My website is not accessible with the DNS when using proxy

I am trying to make a website with a raspberry pi and Cloudflare DNS. I bought my DNS trough Cloudflare and also have the free plan. I am trying to make a simple website but it doesn’t work when i enable the proxy setting. my nginx setting are:
I been following chatGPT tutorials but i don’t understand what is wrong with the Cloudflare side:
also I seem to be able to access the website with the bare IP address. i would like that not to be possible but I don’t understand how to do it. if you need more data about how i set up thing just ask, I am very new to all this.
server {
listen 80;

root /var/www/html;

location / {
    try_files $uri $uri/ =404;


That will be the issue. The server needs to be configured or port 443 and SSL. Pause Cloudflare and make sure it’s loading fine on HTTPS, then it will also work on Cloudflare.

1 Like

okey, i added ssl. the thing is it gave me the certificate but i can’t acces the website from cloudflare dns. i use let’s encrypt with a free cloudflare account. do i need top upload the certificate or use a cloudflare certificate? i don’t get it.

I am afraid you haven’t completed the first step, which is to pause Cloudflare until everything works.

1 Like

i did disable the proxy setting and i remake the server in port 25565 a port that i know it works and ir all worked flawlessly. it look like my isp does some fun stuff with the well known ports or only port 443. i spent way to many hours triying to figure that out.

It currently is not paused and you also need to make sure to use only these ports

oh sorry. i just let the webpage pointing to while i call my isp to allow me to use port 443. i already solve the issue. i now learnt the pause thing. i didn’t knew it. but i took a few moment to re do the server in port 25565 and it worked with the DNS, proxy, and ssl, so it looks it my ISP fault. now i need to deny all triffic to my real IP address and let only connections coming from cloudflare so you can only connect to it trough cloudflare. when i manage to get all that done i’ll let the real webpage up. for the time being i will just let it pointing to

Fair enough, glad it worked.