My Website is down after changing to CloudFlare Nameservers

I changed my Nameservers from Godaddy to Cloudflare Day before yesterday and till yesterday afternoon my website was running well. As soon as the SSL certificate got applied, the website went down, I tried contacting Godaddy but they are unable to ping my IP. But I can see the records are pointing towards my hosting server IP.

Need help on this ASAP. my website is on Development mode and working on Wordpress. Please help with detailed steps.

Thanks in advance

Whats your domain and do you have an HTTPS certificate configured on your server? is the domain name

SSL is with Cloudflare

You also need a certificate on your server.

Okay. I guess Cloudflare is is using letsencrypt free TLS/SSL Certificate .
So should i install that on my hosting ?

I need my Website up somehow . Dont know why as soon i changed my Nameservers it went down

Yes, you should install a Let’s Encrypt certificate or Cloudflare Origin Certificate on your server (it can be a paid one from a provider if you want, but the free options are just as good). Then set your SSL mode in Cloudflare to Full (strict).

1 Like

I have a similar issue. After changing to Cloudflare, my site responded with “Error 525 Handshake Failed”
At this point, I cannot access files, the account is at GoDaddy. It’s a “Basic Managed Wordpress” hosted account, I was able to get to the files yesterday via ftp, but not anymore. It’s not like my other URL, ( also through Cloudflare and works fine) which has Cpanel access to the files. This account does not.
It’s been about 15 hours and still no change in the response. I’ve tried Firefox, Chrome, IE 11 & Opera with no success. The URL that’s not accessable is The other site that’s ok, it I even removed Cloudflare for a bit ( probably not long enough) and nothing changed. Site24X7 reveals the Cloudflare DNS and the all 6 servers refused query. UpTime Robot shows 100% up time. Whatever the reason I’m having such a problem with this one I have no cuse. . but I am suspecting it’s something I’ve overlooked. As stated, my other site works. . not this one. Appreciate any help you can offer. Thanks In Advance, ~T²

525 means there’s no TLS/SSL certificate on your server. A quicker way to bypass Cloudflare is to set the entries in Cloudflare DNS to :grey:.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.