My website images and js cant loading correctly, even I turned to developer mode

I have accessing my website 2 days ago without any problem
I havent changed anythşng on my server
but yesterday I saw that, some images and js cant loading correctly
when I pause the Cloudflare, everything is ok, but when I turned Cloudflare on, the js and some images are broken
even I turned to developer mode on, the js and images cant load correctly
I couldnt understand the problem
my website is magazakent.com
Please help me

you load your site using https, while some of you scripts trying to load with http.

as a quick fix you can go in Cloudflare dashboard->SSL/TLS app
and try to enables this:

Automatic HTTPS Rewrites

and maybe:

Always Use HTTPS

but the proper way would be to fix it at your own side

Hi
Thank you for your reply

I have already
Automatic HTTPS Rewrites turned on
Always Use HTTPS turned on

the two settings was “on” for a long time
and I havent changed any settings for a long time
but the problem suddenly occured yesterday

I think, the Automatic HTTPS rewrites are not working for about 2 days
is there any issue about it ?

Thanks

I have no idea, but just fix you site, a small tip - never depend on services like this so make your site run, you can use at as a fall back safe guard in case you missed something, but just fix your site and make your script use https.

it should always work good without Cloudflare

thank you for your answer

some of my website content loading from

cdn.magazakent.com

is ther any way to auto-rewrite cdn.magazakent.com resourges on Cloudflare ?

Thanks
Regards…

but why?
you need to fix your code - thats the root of the problem

instead of loading the script with

src = “http://script

change it to

src=“https://script”

so simple and remove your dependency on other tools which may not work correctly

thank you for your reply
I have changed resource url to https, but the problem isnt solved

I am using Flexible SSL
so I think
I should remain my website url as “http” only

flexible ssl setting will change all the “http” to “https”

am I right ?

you still have http resourse:

var require = {
        "baseUrl": "http://magazakent.com/pub/static/frontend/Smartwave/porto/tr_TR"
    };

looks like you should change it to https, but consult whoever is in charge of it at your side

This topic was automatically closed after 14 days. New replies are no longer allowed.