My website doesn't use the cache abilities in cloudflare

My website:
dudimazig.co.il

I connected the cloudflare to my website following the instructions and it was loaded in 1.4 seconds, amazing.

I don’t know what happened but I tried it today and I saw it’s loading in 3.5 sometimes 3.1 and sometimes 4.7 seconds, what happened, why is it not loading the website from cache anymore?

Thanks in advance.

Try “cache everything” or changing your cache settings (both can be done via the cloudflare dasboard)

I did,
Cache everything
also saw the edge cache ttl should help and browser cache ttl, so used them as well, but no change, still no change, could it be other things?

Maybe I didn’t connect my server to cloudflare right? but I don’t see no error in the DNS tab…

Could it be that the cached version wasn’t updated? how long does it take cloud flare to update it’s cached versions? can I speed it up?

What’s the results of the speed test? (try running one then show me the results)

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.