My website does not use cloudflare in devtools network tab

I am testing Cloudflare with a dummy website. I have an nginx server and a website set up with Nextjs. I have successfully configured nameservers in the cloudflare dashboard and it is working. But the problem is that I do not see anything related to cloudflare. I have used cdn checker websites to know if I am using cloudflare and turns out I am and if I make a curl request in the terminal there are cloudflare headers but in the browser there are none.

This is from curl command:

curl -I
HTTP/2 200 
date: Fri, 25 Aug 2023 13:49:30 GMT
content-type: text/html; charset=utf-8
vary: Accept-Encoding
vary: Accept-Encoding
x-powered-by: Next.js
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=K3bRQJ7GzycGZW8B2U12xll5M1De8DJ1NkjDity5fwufLKAA%2BGS6xFAy80NC1h2RfKOl6kEpY3j2wpkU6aDAn4KIrLuYAMboBkb33xV0d33iC4mU7DJZjqmTOlwDUzRSODNMCUJyrQ%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 7fc44c7c2ed06939-FRA
alt-svc: h3=":443"; ma=86400

This is from browser network tab:

HTTP/1.1 200 OK
Server: nginx/1.18.0 (Ubuntu)
Date: Fri, 25 Aug 2023 13:50:33 GMT
Content-Type: text/html; charset=utf-8
Transfer-Encoding: chunked
Connection: keep-alive
etag: "bfkjy3wfl330g"
x-powered-by: Next.js
Vary: Accept-Encoding
Content-Encoding: gzip

That may very well be because of the insecure legacy encryption mode you selected on Cloudflare, which is known for breaking sites. You have no valid certificate on your server either.

You best pause Cloudflare and make sure the site loads fine on HTTPS first. Then it should also work on Cloudflare.

1 Like

I have changed my A DNS record IP address on Cloudflare to something else (my old hosting provider’s IP address I think.) and now my website content is gone of course and there is the default page but now Cloudflare is working and I see the response headers from cloudflare. So that means when I enter my IP address is there something wrong with my Nginx setup and it is blocking the Cloudflare?

My Nginx setup:

server {

    location / {
        proxy_pass http://localhost:3333;
        proxy_set_header X-Real-IP  $remote_addr;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $host;

    listen 443 ssl;
    ssl_certificate /etc/letsencrypt/live/;
    ssl_certificate_key /etc/letsencrypt/live/;
    include /etc/letsencrypt/options-ssl-nginx.conf;
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;

Certificates managed by Certbot by the way.

As mentioned

Also make sure your encryption mode is Full Strict.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.