My webhost has changed the DNS, how do I rescan on cloudflare?

dns

#1

Hello, my webhost has moved my hosting account/website to a new server and has changed the DNS.

I had to manually change the DNS from my registrar to the new DNS provided by the webhost.

I still want to use cloudflare but I don’t know how to rescan the DNS settings that I did when I first added my website.

Is there a page from where I can “recheck” my new nameservers or do I have to add them manually from the DNS tab from cloudflare. I see a lot of data there and the old DNS are at “SRV” column and a lot of ips.

From the overview page from Cloudflare I see status paused but no “recheck nameservers” button.


#2

Not that I’m aware of, though it would be a good feature. The only way to rescan your DNS as far as I’m aware is to delete the site and recreate it on the Cloudflare dashboard.


#3

If your host moved to a new server the only thing changing is likely the IP address of the machine. All you have to do is replace in Cloudflare the “A” record ips in https://www.cloudflare.com/a/dns/ yourdomain.com


#4

Hi all, maybe this has an answer? Maybe it does not. This was the only thread I found with the exact problem I have. My hosting provider changed my server and therefore changed my IP address. I thought I could log into Cloudflare and change the Firewall Access Rules then the A Records and finally the SRV Records to the Server Hostname *.com?

I did this yesterday and today all sites on Cloudflare return 521 Error?

No where to rescan DNS records so I deleted all records except A Records, CNAME and MX records hoping it will repopulate the DNS records?

Currently this 521 error is intermittent. Meaning, refresh of my page sometimes resolves my site and sometimes resolves a 521 error. Any input is appreciated.

Respectfully,


#5

DNS only scans once. After that, Cloudflare is your DNS and you have to manually update it.

Your best bet is to open the Cloudflare DNS page and your web host’s DNS page side by side and make sure Cloudflare has all the DNS entries to match those at your web host.


#6

Make sure you have a rewrite (or page rule) sending ALL your traffic to www (or non www) and absolutely you need TWO (2) A records BOTH with the same IP address your host changed to (one A rec for WWW and one for non WWW.


#7

I think this is what you mean. My sites are still intermittent. I think it is changing with the proxy. I am not sure what else to do but delete the site from Cloudflare and rescan?

All the IP address are the same with the updated IPs. I have deleted all caches, in Cloudflare and on the WordPress site and no change.


#8

The record you have a page rule set up for (example.com) and any subdomains you want to be HTTPS will need to be :orange: in the DNS tab, not :grey:. Also, instead of a page rule, try setting “Always use HTTPS” in the crypto tab.


#9

Thanks Judge,

I turned on and waited (4+ hours) turned off (4+ hours) waited and still same. I have four sites here so I can change one and leave it and change another and wait. Still the same. I have left the “Always use HTTPS” as well on.


#10

Ah, so. I would delete the CNAME for WWW and make an A record for www (this is what I meant before). Materially it seems a moot point, BUT it will kick the DNS in the ass and an A record pointing to BOTH www and non-www with the same IP will go round the world a lot differently and quicker than what you have (and @Judge 's point about the orange cloud to boot ++:)


#11

Thank you Stuart

I changed the CNAME record to a WWW (A Record) and have no changes.

I then went to https://ssllabs.com/ssltest to see if that told me anything and it just said everything was A ok.

All sites are intermittent. The site if it helps is https://forthawksupply.com

I used plugins (Really Simple SSL) when setting it up and looked at them and turned off 301 redirect?
no change just errors in the plug in

All four of my sites .htaccess files are different but none are hard coded with an IP address.

The plugins that might affect this are
Really Simple SSL
Wordfence Security
Yoast SEO
Jetpack by WordPress.com
Cloudflare

I try keeping the plugins to a minimum but those would be the ones that might effect it. I jumped ship on my hosting providers “paid” SSL option because I took months and failed setting it up so trashed it for the free options. Anyway think I am at a stand still. I guess I will make a change daily and hope it’s a propagation issue.

Additionally I deleted, added the site back and rescanned the DNS records for this site before I did any of this.


#12

Yes, I saw the site a couple times and then back to a 521. Plugins are not going to affect this unless you have a mis-configuration in SSL. I work on NGINX setup’s so htaccess means nothing except you can push rewrite rules through it. When I mention a page (rewrite rule) to force non-www (which is what I’m thinking you’ve done) understand the reason which is lost to many is www in fact is a sub-domain and why we point it to no www. The reason is, if your site worked on both www and non Google and crawlers would see 2 separate websites and in addition to terrible seo it’s confusing (or can appear broken) to people/browsers. If you’re doing this with .htaccess I believe it’s working but as you say intermittently. If this page rule is in Cloudflare, they have a guide for that and if so and it’s working right you don’t need both that and the .htaccess. I’ve seen both .htaccess and cloudflare page rules get real fussy because of how some of the guides are with wildcards like www.domaindotcom/ and domaindotcom/ pointing to https://domain.com/$1 or /$2 (you have to read the guides to get my drift more).

My question now is - Are you using “Flexible SSL” in the Crypto tab of Cloudflare? If you are you may want to read about this plugin (I used to use this successfully, before I began installing SSL certs on my machines) - https://en-ca.wordpress.org/plugins/cloudflare-flexible-ssl/

somehow cloudflare is stripping the asterisks off the above because of markup *www.domaindotcom/* and *domaindotcom/*


#13

I am using Flexible SSL and everything worked before the migration. I sent my hosting provider an email and they said there are no restrictions for CF. I am thinking your plugin suggestion is the same thing I have already installed https://wordpress.org/plugins/really-simple-ssl/.

I am going to try and change out the plugin and try the one you suggested. I will need to study more of the /$1, /$2 I am terribly lost. Thank you Stuart for your line of thinking I am using it to direct my Google searches. I will keep looking up the page rules. It has to be in there.

Respectfully,


#14

Alright when I came here I was working on three things and wanted a quick fix.
LOL that wasn’t going to happen. Of course not.
Anyway… Here is where I am so far.

I found two articles (Conveniently written like “yesterday”)


First I ran a trace route and got this:

With CF on:

With CF off:

Here is the http://example.com/cdn-cgi/trace

Both articles do basically the same thing but here are my findings on my virtual machine:

Running with Cloudflare off: Port 80

Cloudflare4TestWithCurl

Running with Cloudflare on: Port 80

CurlCloudflareOnPort80

Running with Cloudflare off: Port 443

Running with Cloudflare on: Port 443

Now on 443 it looks to me like all ports are open and working however my site is still intermittent.

Here is one of the Ray IDs if that helps at all.

I am thinking the problem is somewhere in the following text. Like the certificate hasn’t been updated with the new IP address?:

Currently still lost I’ll keep digging. Any input is greatly appreciated.

Respectfully,

P.S.

Here is my only PageRule…