My web site is resolving to an IP address not listed by CloudFlare

I have started getting connection timed out errors (522) this morning and after investigating I have realized that my web site is now resolving to this IP address: 104.25.114.108. I have checked and while this is clearly a valid Cloudflare IP it doesn’t appear in the list of official IP addresses that I used to whitelist on my firewall: https://www.cloudflare.com/ips/

Has anyone else experienced the same behavior lately?

Thanks

It is part of 104.16.0.0/12

You’re right, I didn’t realized that the bitmask was /12…

But that still doesn’t explain the timeouts I have been getting all morning!

Thats a different question and if the address is blocked (not whitelisted) it naturally wont work.

This address is already whitelisted (104.16.0.0/12), this is what I said in my first message!

You said in your first message the address was blocked.

Anyhow, to answer your original question, no I didnt experience any such behaviour. You would need to provide more information for anything more concrete.

Because I initially thought that 104.25.114.108 was a new one (not already whitelisted)!

Sorry for the confusion…

Do you still get 522s? Whats the URL?

Yes but the web site is only accessible from Canada so it probably won’t work for you…

Can you post it nonetheless?

There you go: https://appia-dev.expretio.net/appia

The site actually does load for me
Also at http://sitemeer.com/#https://appia-dev.expretio.net/appia

You can forward the connection IDs of the 522s to support and maybe they can shed some light.

1 Like

Ok thanks a lot for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.