My web site didn't work!

Hello , my website didn’t work after i add to cloudfare last night !! Also i can’t mange my DNS because my website Host is infintyfree a partnaer of cloudfare .
My website : streetpost.fun
Please tell me what should i do ?

Hi,

The site was working before “adding” it to cloudflare?

Your domain registar is ovh.com and the nameservers for that domain are from infinityfree.
How did you add it?
- was it through cpanel >> software >> cloudflare?
or
- manually creating an account with cloudflare?

Edit:
just found this explanation in their forum

I also added it manually, so i had to change the nameservers to cloudflare in my registrar.
Br

Hi @streetpost.me, your site is active under a partial plan where you don’t need to change your nameserver to cloudflare and the partner manages the DNS.

The details from @Rui explain how to remove the site from the partner and add it directly to Cloudflare.

I did a :search: DNS_PROBE_FINISHED_NXDOMAIN #CommunityTip :search: and found this tip, Community Tip - Fixing the DNS PROBE FINISHED NXDOMAIN error

Right now, seems the nameservers are a bit of a mix, https://www.whatsmydns.net/#NS/streetpost.fun.

I did that with c mpanel

I add my domaine with cpanel

Hi,

So its like cloonan said, you are using cloudflare partner integration, the DNS is managed by infinityfree. It should be easier compared to manual method.
Try to put your case in infinity forum, admin can look at your DNS settings and help you.

What i shared in my first post was the manual method, in theory more difficult to configure but has some advantages as mentioned in the link i shared with you, but it all depends on what your project is.

The best of all, its free and you have options :slight_smile:
Don’t give up!

1 Like

Ok … but my website still did not working !!

Did you put your case in infinity forum? what was the answer?
Right now your A record is not pointing to any IP address, its not possible to resolve your website address.

Hello ,
Infintyfree client support said i should enable cloudfare from cpanel , and i did so my website start work again but the protection not working it is not secuire.

What should be protect with cloudfare ?

Your DNS seems OK now, i guess the SSL part is from cloudflare dashboard.
For a complete free configuration set it up as flexible:
Flexible - Encrypts traffic between the browser and Cloudflare

You will have problems in the full config because infinityfree doesn’t accept self signed certificates from cloudflare:
Full - Encrypts end-to-end, using a self signed certificate on the server

The only option that i’m aware is to buy a dedicated certificate.

Hi,

I’ve tested your configuration:

  • bought a domain;
  • create new account in infinityfree;
  • added infinityfree nameservers to my domain;
  • setup quickly a WP blog;
  • integrate it with cloudflare
  • switched from flexibe to full and full to flexible
  • flexible is working.

In your case i think you have it set to full, you are having 525 error:
https://streetpost.fun/

Later today will do more tests with this partner integration, trying to put full ssl and if still necessary help you through.

And if i change it to :
Flexible - Encrypts traffic between the browser and Cloudflare .
I will get problem or not ?

Yes, flexible encrypts traffic between browser and cloudflare.
About what i told you before its not completely correct, its only valid for full strict configuration.
In the full configuration you are able to have the SSL configured at infinityfree (self signed certificate) and cloudflare:

The Full SSL option does not validate SSL certificate authenticity at the origin. A self-signed certificate is allowed at the origin web server.

How to configure SSL at infinityfree:
HTTPS and SSL articles

Two remarks when requesting the SSL at infinityfree:

  1. “Please note that DNS changes can take up to 24 hours to take effect.”

  2. When you are configuring the record names and destination at infinity CNAME records pay attention to the following:
    _acme-challenge | Domain you bought | destination
    _acme-challenge.www | Domain you bought | destination

by default its the “subdomain.epizy.com”, i just noticed i did that mistake in one of the records

This topic was automatically closed after 31 days. New replies are no longer allowed.