My web post-new.php and the post.php is blank page

my web post-new.php and the post.php is blank page
sitegroud worker told us that should contact with you, so i hope you can help us to fix it, thanks in advance!

below it sitgroud worker said to us:
You can also contact the support teams of Cloudflare and Ezoic if you are still seeing blank page on the post.php and post-new.php scripts when accessed from the website’s dashboard, since it happens only when these external services are used. Their support team should be able to advise what the issue could be due to and how to address it.

Who can told us how to fix the problem, thanks


Thank you for asking.

May I ask if there are some indications in the error.log file at the origin host/server? :thinking:

What kind of the WordPress Editor are you using? Gutenberg or Classic?

Just in case, related to the WordPress, I’d suggest you to whitelist your origin host / server / hosting IP address by navigating to the Security → WAF → Tools → IP Access Rules with the action “allow” for your Website and try again.

It knows to happen due to the WordPress using HTTP/1.0 and empty user-agent, therefore while executing WP-Cron or some other related JSON/REST API request via plugin.

I wonder if you’d have to find the IP of that 3rd-party (external) service if some request might be challenged or blocked :thinking:

Otherwise, I’d suggest you to enable WordPress debugging. I’d check .htaccess at the origin host/server, also disable all plugins at WordPress and re-enable one by one.
Double-check what are the settings there.

If it’s WordPress, then it’s the plugin to troubleshoot and debug your theme and plugins.

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine if the redirection is cause by Cloudfalre either by using “Pause” option:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

Otherwise, from my experience, WordPress knows to “hang” and be difficult (especially when using much plugins or at least WooCommerce and similar in combination like multi-language, etc.) to handle on a shared web hosting plan.

Might want to try out to tune-up your PHP values a bit at your server/hosting provider/cPanel if you can:

memory_limit = 256M
max_execution_time = 300
max_input_time = 1000
max_input_vars = 5000 or 7000
post_max_size = 64M
upload_max_filesize = 32M

If you have an integration with a tool such as Ezoic, then you should manage your DNS records and settings related to the Cloudflare there through their interface and not at the official Cloudflare dashboard.

Since you’re also mentioned SiteGround, I wonder where and how did you integrate Cloudflare for your domain name as it could be either:
a) SiteGround + Cloudflare
b) eZoic + Cloudflare

Thank you very much!
my host is sitegroud
CDN is Cloudflare
Now i want to apply ezoic, after integration with Ezoic, Ezoic automatic integration tools is cloddflare.
So now, i can not add new post and edit old post in wordprss Version 6.0.2
The page all is black page post-new.php and wp-admin/post.php?post=4351&action=edit
I have offer a ticket about the issue on ezoic website, but they have not reply us.
I do not know how to sort it out, could you kindly help me and tell us how to resolve it, thanks in advance!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.