My subdomain stopped working since I moved my name servers to coudflare, canyone advise on how to fix this

Yesterday I set up cloudlare for the first time on my Wordress site.
Today the dns has filtered through and the main domain seems to work
I had created a subdomain to test another app eg aptrack.jobwarehouse.co.uk,
That subdomain is now not accessible.
I originally created it when my nameservers were at my hosting company.
Now I’ve moved them to Cloudflare, I wonder if thats the cause?
I’ve searched for any way to add the subdomain via Cloudflare, but I can find no mention.
Can anybody advise?

Greetings,

Thank you for asking.
I am sorry you are experiencing an issue with your sub-domain while using Cloudflare.

When I do a lookup, unfortunately I cannot find any DNS record related for your sub-domain aptrack.jobwarehouse.co.uk. Seems to me like it’s missing. See below related article:

Could you check the DNS tab at Cloudflare dashboard for your domain name and add a missing hostname? Instructions from below article can help you how to add it:

Before moving to Cloudflare, was your Website working over HTTPS connection?

Maybe you do not have a valid SSL certificate installed for your sub-domain at your origin host/server? :thinking:

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

In case you are trying to setup a hostname like www.aptrack.jobwarehouse.co.uk, you would end up having an issue as described at the below article:
Subdomain too deep

To solve this, you would have to use the Advanced Certificate Manager:

Thank you for this.
I didnt realise I needed to add the subdomain in the dns in this way.
I’ve now added an A record for my subdomain.
I’ve set SSL to full strict. It was full.
I do have a certificate and https was already working though I hadn’t yet run formal tests to find any blips
Ill give it a day to come though and test again tomorrow.
Thanks so much for the help. Very impressive.

1 Like

Now when I try to access it, I got Error 526:

I’d suggest you below steps and you could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS (regenerate the SSL certificate via AutoSSL if using cPanel or Let’s Encrypt, or ACME, or Certbot, etc.).
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).
  5. Otherwise, as already mentioned at my first post, you can use Cloudflare Origin CA Certificate.

Great, thank you for feedback!

Maybe you have to wait for DNS propagation time due to the DNS cache at your local ISP provider.

  • if you try with some other Web browser, or Private window (Incognito mode), or via your mobile phone (mobile data, 4G LTE, cellular), or even if possible via VPN …

I checked and now it’s working, can you confirm?

Are you sure? :wink:

$ curl -I https://aptrack.jobwarehouse.co.uk --connect-to ::x.x.x.x
curl: (60) SSL certificate problem: self signed certificate

Yes, to me.

The OP was using Full and switchet to Full (Strict) as instructed, even instructed within the steps to secure and verify if it’s sub-domain is working over HTTPS → did the OP skipped this step?, I don’t know. OP can repeat the steps and re-check in case if the sub-domain is not working over HTTPS while the hostname A aptrack is temporary set to :grey: (DNS-only).
Furthermore, cPanel couldn’t generate SSL certificate due to Cloudflare issue? as it didn’t find and DCV/TXT record (not even needed for AutoSSL) for OP’s domain, cPanel generated a self-signed cert (record was :orange: instead of instructed :grey:) instead of the correct one as a part of the AutoSSL module, therefore it’s working despite using self-signed cert.

I didn’t get the same error output as you stated.

Yes, I just tested and suddenly it works.
I was suspicious of another error I received relating to the SSL adnd my certificate, so I changed back from strict, because Im still using a self signed during development.
Maybe that had an impact.

That explains everything.

Thank you.

Did you check what I posted? The OP can’t be on Full Strict.

You asked does it work, it is working, or not, to you?

Well, considering there is no valid certificate, that can be hardly considered working.

Which the OP has also confirmed in the meantime.

Good, OP will fix this in the production to satisfy your expectations, hopefully.

@ed16, will you?

You should also fix your encryption mode. Right now your whole site is insecure.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.