My subdomain stopped working after I changed my DNS to CloudFlare

I looked at other topics, but none of them actually helped me. Here’s the thing:

  • My domain host is Registro.br
  • I have my main website hosted in Wix, with my main domain (makemymemo.com.br)
  • I have a second website hosted in Iluria, with my subdomain (loja.makemymemo.com.br)

After I changed my DNS at Registro.br from Wix to CloudFlare, my subdomain stopped working. My main website is still working, so far at least.

Here is my configuration at CloudFlare:

What can I do to make my subdomain work?

Try setting your loja entry to :grey: instead of :orange: (just click on the cloud).

I tryed doing that, and still didn’t work. Should I wait a little while or it’s supposed to be instantaneous?

After a while, the subdomain started working again, but it’s not secure. The whole idea of me going through CloudFlare is exactly to make is secure. This happened because I changed to DNS only, insted of Proxied?

But, if I go back to Proxied, it probably will stop working again, won’t it? Any ideas of how to fix it?

You would have to ask Iluria why their subdomain won’t work when it’s proxied by Cloudflare. Sometimes a host won’t respond to CNAME entries if they’re masked, as happens when you proxy with Cloudlfare.

I made it work now. I did a lot of things, don’t know exactly what worked:

  • I switched it back to Proxied;
  • Reactivated the domain on Wix (it had deactivated, but I didn’t really need to change anything, I just needed to ask it to check the DNS again to work);
  • Than I changed the Page Rules on CloudFlare (acording to the configuration Iluria told me to do, I needed to create a rule that would permanently redirect from “loja…” to “https://loja…”). As that wasn’t working, I turned it off.

After doing all that, it worked again.

1 Like