My SSL won't verify after more than 30 hours

My SSL won’t verify after more than 30 hours.

I have added the SSL settings to my DNS records on Cloudflare, but it won’t verify. The settings were provided by Stealth Seminar, which I have copied and done exactly according to their tutorial, but it won’t verify.
I need this to make my webinar run on my sub domain so that I can run facebook ads.

Really frustrated. Does anyone know what’s wrong?. Thank you

What’s the domain? And post a full page screenshot of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates.

Hi Sandro,
thanks for your reply. My domain is foodphotography-masterclass.com
I’m using it for my Teachable account, which uses cloudflare. Now I’m trying to use my domain, to create a subdomain, so I can use the subdomain for my webinar.

The proxy certificate is in place.

image

Is your server certificate configured as well?

Hi Sandro,
thanks for your reply
My website link works, but I’m trying to add a subdomain on my website, that’s what I can’t get to work. The subdomain is through Stealth Seminar, where I’m running my webinar. I’ve followed the instructions exactly, but it won’t verify. please see screen shot

I copied these settings from Stealth into the DNS settings in Cloudflare, but it won’t verify. See below. thanks :slight_smile:

You’ll probably need to set that CNAME record to :grey:.

Did you proxied :orange: the CNAME record?

If yes, you need to unproxy :grey: it.

Also, you do not have webinar.foodphotography-masterclass.com configured. So even if the validation goes through that won’t resolve either.

what does the cloud icon mean? unproxy it?

thank you Eric, I just changed that.

I’ve only done the first step, and was waiting for it to verify. I haven’t done part 2 yet, the proxy. Stealth will sort out the rest, as far as I understand. Once I’ve done the SSL and Proxy, then there server will be able to still run my webinar.

Did you unproxy as I mentioned? That’s necessary for the verification.

Then you need the DNS record and a proper certificate on your server. Where should you point webinar to?

Your service provider appears to have a proper tutorial on that anyhow. You just need to follow their steps and all records should be unproxied anyhow.

Thanks Sandro, it proxied automatically that’s why I left it. I have unproxied it now. So hopefully that will fix it. The server will issue the certificate after I have done the first part. My fingers are crossed, hopefully it will work soon. Thanks for your help

it’s working, yay!!! thanks so much

1 Like

it’s working! Thanks Eric for your help!!!

1 Like