My SSL certificate don´t work

ssl

#1

I don’t understand why my website don’t has SSL security if my website is active on Cloudflare.


#2

#3

Do you have it turned on under the Crypto tab in your Cloudflare dashboard?


#4

yes:

Note: SSL certificate issuance may take up to 24 hours.
Status Active Certificate
This setting was last changed 2 hours ago


#5

Plase if you check now, my page comes out in mode “is not safe”. Please help me


#6

Just checked your site and it appears to load over SSL and has a valid certificate. Some of your resources are being loaded over http though so there’s a mixed content warning rather than the green lock.


#7

Thank but how can I have the green lock?


#8

You’ll need to fixed the mixed content issues on your site so that all of the assets are loaded over https. The linked article above gives some ideas of where to start looking at your site / code to make the changes needed.


#9

Hi. Looking at your homepage I see there is some mixed content: some assets are not being served via HTTPS. This is why you don’t see a green lock.

Specifically, 2 PNG images:

  • drone-logo-2.png
  • cropped-logo-rebel-1.png

If you haven’t already, you should try turning on Automatic HTTPS Rewrites at the bottom of the Crypto tab. This may fix the issue for you.


#10

I have delate this 2 imagenes and I turned on Automatic HTTPS Rewrites, but my website it’s the same??


#11

You may need to clear your browser’s cache. I checked your site’s homepage with Chrome and Firefox and see the lock on both - no more mixed content errors.

However other pages still show some mixed content.

I noticed you are using Wordpress. Have you changed the Wordpress URL in Settings > General to use ‘https’ instead of ‘http’?


#12

Yes I change everything, now if you check my website only the “home page” have “SSL” and the other page don’t have that. :frowning:


#13

Oh Andy, thank, I just needed to update page by page in wordpress


#14

Yes I did a quick sweep of your site and it looks like most (if not all) pages are now :lock:


#15

I’m having the same issue. My domains are active but I don’t have a certificate listed and I get a “your connection to this site is insecure”. Am I missing something? www.dougrugh.com Thanks


#16

Does it say that your :cert: was issued when you look in your Cloudflare account? You may also want to check to make sure you aren’t loading any resources/apps over HTTP.