My SSL certificate appears as self signed in Cpanel and i cant acess my website via wifi

My SSL certificate appears as self signed in Cpanel and i cant acess my website via wifi cause of it.
I dont know what the problem is but its causing my website to appear as unsafe to my wifi provider

If you recently added your domain name to your Cloudflare account, therefore, DNS records were proxied and :orange: , and in case your Website hadn’t had a valid SSL certificate since before, the cPanel tried to generate AutoSSL but failed to do so because the returned IP address was resolving to the Cloudflare’s IP network and not the original origin host/server IP. Therefrom, cPanel generated a self-signed SSL certificate for your domain name.

Otherwise, may I ask if you’re using Cloudflare Origin CA Certificate, which could also result like the described case? :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Last but not least, kindly have a look here for more information regarding SSL settings at the SSL/TLS tab on Cloudflare dashboard:


Ok so i think i fixed the certificate issue but i still cant acess my site through my internet unless i use a VPN, on mobile data it also works

This is the error my vpn gives me, but it works on my 4G so i dont understand what the problem is

I enabled HSTS and now the site works, but only in microfosoft edge, the site still give me 403 FORBIDDEN when i try to acess it without vpn on google

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.