My srv record dosent work

Hello there i have a problem with my srv record dosent work i have a record and srv record for i port i want but dosen’t work the domain is greekroadlife.ml

Could you show a screenshot of your current SRV record? That might help us give you pointers on what is going wrong.

Also a small explanation on what you are trying to achieve with the SRV record could greatly benefit the people here willing to help out.

well i am try have a port working with srv on my domain because i dont want to write it down every time also it faster and maybe want change the port so it will be great to make it work

Anyone have any idea?

@dimosthenis20
Sorry for not responding earlier, for some reason I didn’t get a notification about your response. Next time ping me when you respond :slightly_smiling_face:

What are you trying to achieve? The txAdmin is a web application if I am not mistaken (source) SRV doesn’t work on web-based panels if I’m correct. You will need to host the panel on 80 or 443 (preferred) if you want to connect to it without a port number. Read more about how SRV doesn’t work for HTTP/HTTPS https://serverfault.com/a/830230

@Knagie well it a resource for a server i have and yes have web panel but it not and working a different port as you see

Did you choose .ml for Μυτιλήνη? My family is from there. :smile:

You can change the port for the webserver to 443/80 in the config of txAdmin if you don’t want to add the port number. There is no other option to get your page to show without the port number sadly.

You can change it under txAdminPort

ConVars

  • txAdminPort: The TCP port to use as HTTP Server. The default is 40120 .

Taken from https://github.com/tabarra/txAdmin

@intr0 I’m guessing it is because it is a free TLD to use

@Knagie if i do that after if i want to put a forum i have to change it again

I’m not sure I understand what you mean. Do you mean you can only change this on install? I’m not well known with txAdmin and just using the information I found on the aforementioned GitHub repository.

@Knagie no i mean what if i want put a forum which use the 80 that will not be problem?

Without extra configuration of the web-server it will. But in Apache and Nginx you can have multiple websites on the same web-server. In Apache these are called Virtual Hosts, on Nginx they are called Server Blocks.

I’m not to knowledgeable on them but I am sure there are people around here that do have the knowledge to give some pointers.

Yeah. It’s just the whole “Greek road life” thing. Oh well.

@intr0 @Knagie that is how the server it called and i will try that you suggest

The SRV record here is for panel.greekroadlife.ml, not greekroadlife.ml. Is that intentional? If you want to change it to the latter, set Name to @.

Also, your target is invalid if greekroadlife.ml is proxied. You’ll need to set it to something that doesn’t have the Cloudflare proxy enabled.

@Zenexer i try that too didn’t work

Could you take a screenshot of the settings you attempted following my recommendations?

Indeed as @Zenexer said greekroadlife.ml should not be proxied (it should show a grey cloud) for it to work at all with the port (40120) behind it.

@dimosthenis20 a suggestion:
Make a new A record, for example, txadmin.greekroadlife.ml pointing to the IP address of the server. Then make sure there is a grey cloud showing for that record. Then try changing the “Target” of the SRV record to txadmin.greekroadlife.ml.

If that doesn’t work (which I doubt it will, but worth a try) you will need to change the port as mentioned here My srv record dosent work and here My srv record dosent work

After setting the server to port 80 or 443 you can just set panel.greekroadlife.ml to the IP address of the server and leave it on the orange cloud as well if you want as HTTP(s) traffic goes through Cloudflare.

@Zenexer

I looked into txAdmin. I see no indication that txAdmin supports SRV records. Because it’s a web application, you won’t be able to use an SRV record. HTTP doesn’t support SRV.