My site's https url is not working after activating cloudflare. How to troubleshoot?

My site’s https, origin hosted at bluehost, is not working after activating bluehost.
Under the crypto tab, it says that issuing a certificate may take up to 24 hours. However, I had my own lets encrypt certificate on bluehost.
I tried setting the mode to full (strict) but it didn’t seem to change much. For now, I have put cloudflare on pause.
Do I need to check any settings in particular to make it work?
Thanks,
v

Keep the LE Cert on Bluehost so that end is secured. Give the Cloudflare one a bit of time to set up.

Thanks @sdayman, I just wanted to know if this is expected behaviour or have I fucked things up.

1 Like

How accurate is this tool: https://checkforcloudflare.selesti.com
Should I wait for all servers locations to be using cloudflare DNS?

I don’t think it’s entirely accurate, as it says my sites are not enabled in Spain and Netherlands.

I prefer: https://www.whatsmydns.net/

2 Likes

Thanks mate. Really helpful.

2 Likes

This topic was automatically closed after 31 days. New replies are no longer allowed.