My site won't redirect or open with Iran IPs

Hello,
I have a really strange problem.
My site configuration is done on Cloudflare and I been using the service for 10 days now.
Today I came up with a problem that my site from HTTP protocol won’t redirect to HTTPS or even open it with IRAN Ips shows two error but at the same time if I connect with a VPN service no matter the country it opens normally!

These are two error that I get with Iranian IPs:
Gateway Timeout
and
unable to road trip HTTP request to upstream: EOF

-My SSL mode is on Full.

-Edge Certificates options are configured like this:
The Always Use HTTPS option is enabled.
The Opportunistic Encryption option is enabled.
The TLS 1.3 option is enabeld.
The Automatic HTTPS Rewrites option is enabled.

*The only option that is disabled is “HTTP Strict Transport Security (HSTS)”

-The origin server is empty. (I have done nothing in this section)

Also, I have created a two-page rule like this but still won’t Iranian IPs not working:
www/AND/http://example.com/*
Forwarding URL (Status Code: 302 - Temporary Redirect, Url: https://example.com/$1)

I will be so grateful if you help me to figure out what is the problem and how to fix it.
Thanks

Hi Mani,

This problem was appearing to me in last 24hrs.

First of all, did you enable DNSSEC ?

If yes, please disable that. it should help you to solve this problem. It’s because of Iranian TIC problems!

If no, check if cloudflare IPS has been added to your firewall white list or not, if not, add it, you can find the ips here:

1 Like

Hello,

The DNSSEC is disabled and not been enabled before.
Also Cloudflare IPS and in the white list see if I miss any of the themes.

Best regards

This topic was automatically closed after 30 days. New replies are no longer allowed.