My site not working with https for security

ssl

#1

I went into go daddy and changed up what was requested to do. It’s been a couple of days and still nothing. This is all new to me and looks like a great way without having to spend money to be secure. Am I missing something or not doing something correctly?


Still not http to https
#2

Currently, that site is not going through Cloudflare. Your DNS records should have an option to enable or disable Cloudflare. Is this set up through a Cloudflare Partner host?


#3

I tried your link and it didn’t work for me. I am having problems with this too. No luck so far.


#4

Replied on your other thread:


#5

Thank you for getting back!! Really appreciate! Is that a setting thru Cloudflare? Thought I did all of the recommended steps.


#6

DNS records on cloudflare were set to automatic.


#7

The DNS entry should have a :orange: for it to use Cloudflare. It’s probably currently set to :grey:.


#8

Ah, yes, I set all of those to gray. Thought that meant they were set. Should they all be orange? Man, thank you!!! So I did set them all orange. That should do it yes? Thank you so much!!!


#9

So I set all fields to the orange cloud. There is a message on the top saying;

DNS Records

A, AAAA, and CNAME records can have their traffic routed through the Cloudflare system. Add more records using this form, and click the cloud next to each record to toggle Cloudflare on or off.


#10

Oh no, so with all the clouds orange, it is giving me this error when I check the site on a browser: ERR_SSL_VERSION_OR_CIPHER_MISMATCH


#11

Update!! I only set the top 3 to orange. I have about 7 sites. All are working except markonivision.com and sickaf.net. But for example botistudios.com is working along with the others. Why are the 2 not working. Ugh!!!


#12

sickaf.net is in a redirect loop.

  • You probably have Always Use HTTPS turned on here at Cloudflare. A 301 redirect sends the browser to https. This is good.
  • There’s a 302 redirect at https that sends the browser to http. This causes the redirect loop to the above redirect.

Check your htaccess or other server settings that redirect HTTPS connections to HTTP.

markonivision.com has an SSL error. Check the Crypto settings at Cloudflare. Status should be Active Certificate. I suspect it’s saying something like “Authorizing Certificate.”


#13

Okay, checked in the Crypto settings. For markonivision.com it is showing as Authorizing Certificate. For sickaf.net it shows as Active Certificate. But neither are working. I still have the same problem. My other urls work (botistudios.com , etc.)

Where do I check my thaccess or any other server setting that would redirect? I have gone thru the settings on Cloudflare and they all appear to be set to the same settings.

Thank you again, as I am learning by doing here!!!


#14

How long has markonivision been Authorizing Certificate? It usually says something like “Last changed on …” You should open a Support Ticket if it’s taking more than 24 hours.
https://support.cloudflare.com/hc/en-us/requests

As for sickaf, something needs to be changed on the server. Are you running Wordpress or something similar? For the SSL setting here, is it Flexible, or Full?


#15

Thank you again! i opened a ticket for markonivision.com. So for sickaf where would look to do that? Site is on wordpress.


#16

What’s the SSL setting for sickaf? Flexible or Full? This is on Cloudflare’s Crypto settings page in the SSL section at the top.

If it’s Flexible, give this plugin a try: https://wordpress.org/plugins/cloudflare-flexible-ssl/

Make sure you read their Full Implementation Guide.


#17

I had it set to full, so I should set to flexible and try the plugin perhaps then yes?


#18

In Wordpress, for General Settings, does the URL for your site use HTTP or HTTPS? I’m still trying to figure out if you have a valid certificate on your server.

Just as an experiment, set SSL to Flexible and see what happens. Don’t try the plugin just yet

Since you mentioned you have 7 sites, are they all hosted in the same way? Just to research, start comparing SSL settings between all of them: SSL Status (should be Active) and the Setting (Off, Flexible, or Full/Strict)


#19

This topic was automatically closed after 14 days. New replies are no longer allowed.