My Site not resolving after moving to Free Cloudflare


Hello All, I’m new to this…

I could no longer afford the cost of an SSL Cert, so I thought moving my DNS over to CloudFlare for free and have a shared SSL would be best… However, it’s been a full day and my site can’t be reached.
I moved from NetworkSolutions DNS to CloudFlare…

Domain is:

For your records, this is a confirmation of your nameserver change before Cloudflare and on Cloudflare:


Thanks for you help…



Your site passes through Cloudflare, and sends a 301 redirect back to - even when you try to load - thereby causing a redirect loop - unless you played with page rules in Cloudflare, it is likely that your server configuration or application is doing this…

Do you have SSL/TLS set up in the origin to accept those connections? If not, and if you’re using “Flexible” SSL mode under “Crypto” tab, maybe Cloudflare can’t get your site over HTTPS, so falls back to HTTP, and then the HTTP one redirects to HTTPS? Also see:

By the way, the cost for certificates is essentially “free” if you can install them yourself, Let’s Encrypt gives you free certificates. Alternatively if you access only through Cloudflare, you could install Cloudflare’s free “origin certificate” which will secure the traffic between Cloudflare and your server (but give an error on a regular browser accessing your server directly).



Wow… why did I think this would be simple…
Now I seem to be stuck in some “Crypto” endless redirect loooOOooop… possibly… For choosing Flexible because it’s bends to easy …

Hmmm… were do I go from here…



If you don’t want Cloudflare->Yourserver to use HTTPS (and by that opening yourself to MITM attacks!) - You simply need to configure your server/application to serve traffic on HTTP as if there’s no SSL, and remove all SSL. Basically revert your site to work as plain HTTP, and then apply Cloudflare’s service on top of that. If you have some CMS that has a “Base URL” setting, set that back to - that way your server won’t do redirects, Cloudflare will do the HTTPS->HTTP conversion, and Cloudflare also has an option to re-write your URLs in the domain so they become “https://” for the clients (to avoid “mixed content” issues) even if the server sends them as “http://”.



Thanks Shimi … I will do that and report back…


closed #6

This topic was automatically closed after 31 days. New replies are no longer allowed.