My site is "under development" for about 1.7% of visitors (title edited)

My site is showing a “this site is under development” message when viewed from a PC on wifi, but works perfectly on a wired connection, or on an android phone on wifi. I’ve asked others to check and they seem to confirm what I am seeing, though it wasn’t a big sample size. Does anyone have any idea how I could correct this?

The site is


Nice looking site! So, yes, it works for me.

How long has the site been on Cloudflare? It could be a DNS propagation delay which can take up to 48 hours.


It’s been like this for about six months.
I’ve never had the time to solve it until now!

On the PC, pop open Dev Tools (F12 in Chrome) and watch the Network Tab for your site. You can compare the IP address of WiFi vs Wired. Note that ‘www’ forwards to non-www, which is just fine, but see if Wired vs WiFi also forwards to non-www.

I’m on IPv6, so your address may look different, but it should match between your WiFi and Wired:

1 Like

Thank you for helping!

I see this on wireless:

And on wired:

I don’t see “www” anywhere.

You probably won’t. That part doesn’t seem to be the issue, as the redirect to non-www works.

I see your Wireless was using the same IP address as my test.

Have you tried forcing a refresh, or private/incognito mode? Though it doesn’t explain why others see the same. I just tried wired and wireless on my Mac and it works through both connections.

1 Like

Do you mean “purge cash” for refresh? I have tried that. I’ve also tried developer mode.
Private mode gives the same result, as you guessed. Cleaning my browser’s cache doesn’t help. I’ve even tried using Edge, with the same result. I’m pretty baffled!

You’re not the only one. Especially since it’s the same IP address I used. These others you asked, are they local to you? Are they seeing the same IPv6 (wireless) and IPv4 (wired) situation?

For the PC, my next suggestion would be to comb through your DNS settings and set the DNS Servers to (or for both wired and wireless networks and see if that helps. Note your current DNS server addresses in case you want to put them back.

1 Like

I decided to do a test. I switched my desktop PC to wifi and connected the ethernet cable to the laptop.

Desktop PC still works on wifi.
Laptop on Ethernet works! (Finally!) And it continues to work after I switch back to wifi, even after a reboot. So I think that puts this theory to bed.
Both have the same IP as I reported earlier.

The folks who reported the same issue were just people on Twitter after I shared the site. I can try asking around again on there or Discord. Hopefully if it’s broken for someone else still they’d be willing to look up their IP info. I’ve lost my own test case.

Do you still think the test you suggested it worth it, with this new information? I know nothing about DNS settings so editing them makes me a bit nervous.

Don’t change anything at your site or Cloudflare. I’m pretty sure this is some sort of localized issue.

1 Like

Ok! I just checked on two more devices (both wireless), and it’s working in all cases. Maybe something sorted itself out in the months since I worked on this and my laptop still had some bad data on it. I’ll check with people on Twitter to see if anyone else has an issue.

Thank you for your help, and I am glad you think the site is nice looking!

1 Like

Out of around 250 unique visitors over the past three hours, two people have gotten the “Site is under development” message. Both were accessing it from their phones. Both might be able to share more info, but I’m waiting for someone who has the problem on PC.

1 Like

Reports are starting to come in.
That makes five people who are seeing the development message. I’m going to check and see if the others have tried to visit the site before.

That’s interesting that they see a cached version. Cloudflare isn’t caching the home page, so maybe they should try a forced refresh to clear their browser cache.

1 Like

In this case the IP couldn’t be found at all. Hopefully there’s some useful info here:

I’m not sure how they got that screen in Network, but the console messages show that something is loading.

1 Like

I got this update from the person who shared the first report:
“I get a different IP on PC:”

I’m checking if everyone else who is having trouble has tried to visit the site in the past.

That’s acceptable. Cloudflare assigned four IP addresses to your domain:

1 Like

She said this is the first time visiting the page, and is happy to help. Let me know what questions I can pass along. :slight_smile:

Edit (since I am out of posts for my user level): More reports are coming in. It’s a mix of first time visitors and people who have visited in the past. (some successfully!) All are reporting IP addresses in the list you posted above.

Hey there @DanaENight,

It looks like you have three “A” records in the Cloudflare dashboard for your zone. When there are multiple records, Cloudflare balances traffic between the records. It looks like in this case that one of these IP addresses returns the “This site is under development” page, whilst the others do not. Are you able to remove the A record for “” pointing to the address ending with “130” to see if this resolves the issue? You will likely then need to purge the cache again as some parts of the Cloudflare edge network will have stored this version of the site.