My site is still insecure (no https)

Hello,

I added my personal website a few days ago but my site is still insecure (no https).
Can you help me to solve this problem?
Thanks in advance

Have you enabled it in ssl-tls > edge-certificates?

Thank you for your reply.
Yes I added my site and it is marked “active”

Hi @elkhicham20,

Can you share the domain so we can have a look?

Thank you for your reply.
the website is: http://anwar2.tk
Thank you

By default, Cloudflare provide a Flexible proxy for your website. If you want enable a SSL connection, you need change your SSL settings from “Off” to “Flexible” or “Full”

46

The site seems to load over HTTPS, but is not redirected there by default. If you enable ‘Always Use HTTPS’ under SSL/TLS > Edge Certificates then it should work!

Hi,
I thank you very much for your answers. Sorry I was away.
Should these changes to my configuration be done in my Cpanel or Cloudflare?
If it’s at Cloudflare, thank you for telling me how.
Once again, thank you very much for your help.

This should be done in your Cloudflare dashboard.

Hi,
First of all thank you for your answer.
I just found this option. I changed it to “Flexible”.
I will see what will happen next.
Must wait how long to see the change?
Thank you so much.

You should ideally set this to Full (strict). Flexible is not secure.

It can take a short while for you to see the redirect.

Hi,
My website is inaccessible. Is this normal?
Thank you

Le dim. 29 sept. 2019 à 16:05, domjh via Cloudflare Community [email protected] a écrit :

The redirect to HTTPS is now working, but there is now a redirect loop. Can you change from Flexible to Full (strict)?

If that doesn’t work, please see this info:

The errors “The page isn’t redirecting properly” or “ERR_TOO_MANY_REDIRECTS” indicates a redirect loop between Cloudflare and your origin server. The easiest fix for this is to remove the redirect on your origin server. For a more detailed set of options, review the troubleshooting suggestions in this Community Tip. Let us know if you continue to see issues after trying the Quick Fix Ideas in the Tip, we’re happy to help further.

Ok I just have to correct the configuration. Thank you for seeing the picture.
Is this good?

Le dim. 29 sept. 2019 à 16:46, domjh via Cloudflare Community [email protected] a écrit :

Perfect. it works perfectly.
Thank you so much.

Le dim. 29 sept. 2019 à 16:54, domjh via Cloudflare Community [email protected] a écrit :

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.