My site is not opening with https

After doing sign-up and setting all settings for SSL still my website not opening with https and when tried using https it shows SSL not enabled for
Please give some suggestions.

1 Like

The primary issue is that your server does not have a valid certificate for your domain nor even serves your content at all under HTTPS.

You should contact your host and get a valid certificate set up on your server.

1 Like

Actually I bought domain from and hosting from Now could you please guide me what to do.

1 Like

You probably have to change hosting, as that host does not offer SSL AFAIK, but that is something you need to clarify with them. If they dont you need to change to a host who does.

1 Like

Ok I got you. Thanks Sandro

1 Like

After changing the hosting from to still then my site is not opening from HTTPS, and shows an error message.
Please give some suggestions.

1 Like

Do u have flexible ssl or full (strict) in Cloudflare SSL/TLS app?

yes i switched to full

do u have ssl certificate for your domain in your new host?

You mean in, it asking to buy.

I bought domain from and hosting from

in case u have cpanel/whm u can install free letsencrypt ssl.

Another way is keeping SSL flexible and install Cloudflare flexible SSL (this plugin is third party) in wordpress.

so now i need to buy hoosting from wordpress?

No need to buy anything. U just need to install Free SSL certificate from letscrypt.

Or run Cloudflare as flexible ssl.

ok first trying to set the setting for flexible ssl

No, dont do that. As I mentioned in the original thread, get a certificate. You want a secure site, right?

Advising to use Flexible couldnt be worse advice.

My website :

If you feel comfortable sharing your IP address here, do so.

Same issue as before you switched the host, still no valid certificate.

You can remove the posting with the IP address if you want.