My site is not cached and diagnostic showed SSL error

Hello. My site htttps://wnfdiary.com have a valid Cloudflare certificate, but I am getting missed cf-cache on the site. I put cache all rule already and it didn’t work. Any idea what can I check? When I posted a ticket for support the diagnostic showed some error for SSL. All ssl tests are A grade, so I don’t know what else can I do.

While i am waiting for their response I am asking here. Thank you guys.

SSL looks fine. What’s weird is I’m not seeing cf-cache-status headers for static resources. What Page Rules did you add? You can post a screenshot of the relevant Page Rules section if that would be easier.

:wave: @sdayman,

Agreed. Sounds like there is a bypass cache page rule in place, otherwise there would be cache status headers.

-OG

1 Like

Hello. Here is my rule

In that same rule, add Edge Cache TTL for the desired amount of time. 1 Day would be a good place to start.

EDIT: Go figure…now I’m seeing cf-cache-status headers with HITs.

:wave: @andrej.tomazin2,

If no other changes have been made, then it is also possible you were in Developer Mode, as the resources are now returning a cf-cache-status of HIT.

-OG

Hmm where can you see HITs? I am using Redbot. https://redbot.org/?uri=https%3A%2F%2Fwnfdiary.com%2F

I use Dev Tools in Firefox, but you can see them in a Page Test. Click the Detail Arrow for image requests:

Aha I see. Thank you. So now I need to wait probably a day or two, everything will transfer right? One question, if I change something in CSS, do I need to make purge all CF? will also photos be cached? I am missing some monitoring how many data is transferred and if it is transferring at all. Cant wait my HTML will be transferred, so I can get some speed finally

:wave: @andrej.tomazin2,

Your origin is almost certainly telling Cloudflare not to cache the html for that page. The static assets are being cached.

https://support.cloudflare.com/hc/en-us/articles/115003206852-Origin-Cache-Control

-OG

Hmmm should I import Origin Certificate from CF into Hostgator? Or can I change this setting somewhere. I am using WP-rocket for my Caching

Your main page is set for caching, as is everything else. It shows a MISS in the Pingdom link above.

As it’s a Wordpress site, you need to bypass cache for Admin and Login. Add two more Page Rules above the one you posted. Match *wnfdiary.com/wp-admin* and set Cache Level to Bypass. And the other rule should match *wnfdiary.com/wp-login.php

Like this is ok?

EDIT: Do I need wildcard also for wp-admin?

Thank you

Sorry, due to the way the forum treats asterisks, the wildcards didn’t show up. Yes, you need some wildcards.

Don’t worry. Thank you. it is all set like you said. My site and I found also a photo is still on MISS. Any idea what can we still try?

What’s the URL for that photo?

MISSes tend to stay a MISS until it’s hit enough times at that datacenter for all the edge servers to get it into their caches. A MISS also implies that it can become a HIT at some point, though if you set a really short expiration time, it’ll keep purging. Not likely, though.

This is a photo https://wnfdiary.com/wp-content/uploads/2018/10/Hoi-an-photography-2-960x640.jpg. In next test it shows HIT. I added edge cache TTL: a month rule. Now I don’t get notification in google speed test for bad response time anymore. Maybe after a time my www will become hit as well.

EDIT: To quick to make conclusion. I got 1 second server response again. This must be still because it is fetching html from my server.

The photo and the home page give me one MISS, then HITs after that. I think you have it properly set up now.

Thank you very much friend!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.