My site is down - i'm wondering if i have a dns problem

We recently moved from Godaddy to cloudflare. Well we moved sometime back and cloudflare just added their fee to the end of the godaddy time period. Well godaddy just ran out and now our site is down. What do I do?

Hi @help5,

Are we talking about Cloudflare Registrar? Can you share the domain in question?

www.community-christian.net

That domain seems to be registered with GoDaddy, not Cloudflare.

The nameservers seem to have to changed from Cloudflare to GoDaddy today https://securitytrails.com/domain/community-christian.net/history/ns

Can you tell me how to fix that?

You need to change the nameservers at GoDaddy to point back to Cloudflare.

On the godaddy site it says that it’s expired. I can still see the DNS. What do I need to change them to specifically?

i thought i did this when i moved the site here months ago

WHOIS shows the expiry as 21/10/20, however there are quite a few statuses showing for your domain. I would recommend contacting GoDaddy about this.

The nameservers were pointed to Cloudflare, but they got changed back to GoDaddy today (I guess by GoDaddy).

thank you

1 Like

okay i called godaddy. they said it was transferred. It says here that cloudflare is the registrar but it’s still not working

when i go to https://www.whatsmydns.net/ it is showing the dns pointing to the wrong place

It all seems to be in order and working now :slight_smile:

Looks like they fixed it:

[email protected] ~ $ dig ns community-christian.net +short
norm.ns.cloudflare.com.
sandy.ns.cloudflare.com.
[email protected] ~ $ whois community-christian.net
   Domain Name: COMMUNITY-CHRISTIAN.NET
   Registry Domain ID: 11560570_DOMAIN_NET-VRSN
   Registrar WHOIS Server: whois.cloudflare.com
   Registrar URL: http://www.cloudflare.com
   Updated Date: 2019-10-26T18:38:01Z
   Creation Date: 1999-10-21T20:29:11Z
   Registry Expiry Date: 2020-10-21T20:29:11Z
   Registrar: CloudFlare, Inc.
   Registrar IANA ID: 1910
   Registrar Abuse Contact Email:
   Registrar Abuse Contact Phone:
   Domain Status: clientTransferProhibited https://icann.org/epp#clientTransferProhibited
   Name Server: NORM.NS.CLOUDFLARE.COM
   Name Server: SANDY.NS.CLOUDFLARE.COM
   DNSSEC: unsigned
   URL of the ICANN Whois Inaccuracy Complaint Form: https://www.icann.org/wicf/
>>> Last update of whois database: 2019-10-26T19:03:06Z <<<

For more information on Whois status codes, please visit https://icann.org/epp

whatismydns.net looks OK too.

that’s weird i still can’t get it to pull up when i type in the address

I suspect it will be cached on your end, it should clear.

If you want to check, can you run the following commands from a Windows command line and post the output?

ping community-christian.net
nslookup community-christian.net

The dns for my host site is not the one seen there

ping

did i do that right?

1 Like

Yep :+1:

That confirms my thought, DNS propagation / caching issue on your end. You could try rebooting your router, or just wait for it to clear in time.