My site doesn't work with www on the front

If I type in my domain (tewayforwomen.com.au) with www (www.tewayforwomen.com.au) at the start it doesn’t function.

There is a page rule of this already in place:

and a DNS record of this

If I try to upload an A level of www with the dummy IP it says that a CNAME already exists with that host.

Any ideas???

For Page Rules to work your site needs to be :orange:. The Page Rule seems correct.

Also, A records and CNAME records can’t co-exist, that’s correct.

Thanks,

So should I get ride of the CNAME www and make it an A record?

I’m just concerned that the CNAME www does something and if I remove it something else will go wrong.

It doesn’t really matter which one you have, it won’t go to the origin regardless. Simply leave the CNAME and click the :grey:.

Thanks

I was doing that and it would automatically change back for some reason.

Now I have deleted the CNAME and made an A record with www and this IP 192.0.2.1

This seems to work.

Now I need to force https on this link http://www.tewayforwomen.com.au/strategy and it should redirect to https://tewayforwomen.com.au/clarity/

Which is what I need to happen.

How would I force https on this page do you know?

You are right, didn’t think it was pointing to ClickFunnels, they are on Cloudflare themselves… I don’t know why it even shows the :grey: now.

The solution you did would have been what I would have suggested.

To force HTTPS simply enable the “Always Use HTTPS” toggle in the Crypto tab. For the page redirect use a Page Rule (skip the http(s) in the front, it doesn’t need to be there with the other setting).

1 Like

Absolute legend thank you so much!!

1 Like